Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595101 - SELinux is preventing /usr/libexec/gdm-simple-slave "write" access on /var/log/wtmp.
Summary: SELinux is preventing /usr/libexec/gdm-simple-slave "write" access on /v...
Keywords:
Status: CLOSED DUPLICATE of bug 595100
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-23 11:19 UTC by ghostwik
Modified: 2010-05-24 12:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-24 12:37:20 UTC


Attachments (Terms of Use)

Description ghostwik 2010-05-23 11:19:00 UTC
Summary:

SELinux is preventing /usr/libexec/gdm-simple-slave "write" access on
/var/log/wtmp.

Detailed Description:

SELinux denied access requested by gdm-simple-slav. It is not expected that this
access is required by gdm-simple-slav and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_t:s0
Target Objects                /var/log/wtmp [ file ]
Source                        gdm-simple-slav
Source Path                   /usr/libexec/gdm-simple-slave
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gdm-2.30.2-1.fc13
Target RPM Packages           initscripts-9.12-1.fc13
Policy RPM                    selinux-policy-3.7.19-15.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux grepfruit 2.6.33.4-95.fc13.x86_64 #1 SMP Thu
                              May 13 05:16:23 UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Sun 23 May 2010 01:11:40 PM CEST
Last Seen                     Sun 23 May 2010 01:11:40 PM CEST
Local ID                      2c478195-2f09-4155-83e3-ac79563c5bc1
Line Numbers                  

Raw Audit Messages            

node=grepfruit type=AVC msg=audit(1274613100.779:21646): avc:  denied  { write } for  pid=1449 comm="gdm-simple-slav" name="wtmp" dev=sda1 ino=366386 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_t:s0 tclass=file

node=grepfruit type=SYSCALL msg=audit(1274613100.779:21646): arch=c000003e syscall=2 success=no exit=-13 a0=426c88 a1=1 a2=2 a3=1 items=0 ppid=1407 pid=1449 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="gdm-simple-slav" exe="/usr/libexec/gdm-simple-slave" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gdm-simple-slav,xdm_t,var_t,file,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t var_t:file write;

Comment 1 Miroslav Grepl 2010-05-24 12:37:20 UTC

*** This bug has been marked as a duplicate of bug 595100 ***


Note You need to log in before you can comment on or make changes to this bug.