Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595036 - SELinux is preventing /usr/sbin/abrtd "read" access on abrt.
Summary: SELinux is preventing /usr/sbin/abrtd "read" access on abrt.
Keywords:
Status: CLOSED DUPLICATE of bug 593906
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jiri Moskovcak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:477e893a8ff...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-23 01:45 UTC by GoinEasy9
Modified: 2015-02-01 22:52 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-24 15:23:24 UTC


Attachments (Terms of Use)
/var/log/audit/audit.log (deleted)
2010-05-24 19:34 UTC, GoinEasy9
no flags Details
audit.log (deleted)
2010-05-26 16:47 UTC, atswartz
no flags Details

Description GoinEasy9 2010-05-23 01:45:10 UTC
Summary:

SELinux is preventing /usr/sbin/abrtd "read" access on abrt.

Detailed Description:

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_spool_t:s0
Target Objects                abrt [ dir ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-1.1.3-1.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-15.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.34-11.fc14.i686.PAE #1 SMP
                              Sat May 22 01:03:27 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Sat 22 May 2010 09:41:25 PM EDT
Last Seen                     Sat 22 May 2010 09:41:25 PM EDT
Local ID                      0e039f3c-e5d5-4718-a282-d01521739f68
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274578885.302:6): avc:  denied  { read } for  pid=1321 comm="abrtd" name="abrt" dev=sda2 ino=1049785 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_spool_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1274578885.302:6): arch=40000003 syscall=292 success=no exit=-13 a0=5 a1=8064e75 a2=180 a3=0 items=0 ppid=1320 pid=1321 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="abrtd" exe="/usr/sbin/abrtd" subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,abrtd,abrt_t,var_spool_t,dir,read
audit2allow suggests:

#============= abrt_t ==============
allow abrt_t var_spool_t:dir read;

Comment 1 GoinEasy9 2010-05-23 02:04:40 UTC
abrt daemon failed to start.  SELinux is also preventing /usr/sbin/abrtd "setaddr" access on abrt.  Seems to be a continuation of the same problem that caused bug #593906.  abrt daemon hasn't started since the update on 5/20.  I executed the commands:

# mkdir /var/spool/abrt
# restorecon -R -v /var/spool/abrt

on 5/20 when the problem first appeared, but it seems it didn't fix everything.  I don't use SELinux on my regular installs, so I still quite an amateur at trying to generate local policy modules.  Since abrt shouldn't need this type of access, I'll wait to see if it is a bug, or if it is something I should fix myself in SELinux policy.
I know if I disable SELinux this alert will go away, but I'd rather learn SELinux by using it on my rawhide install, I just need confirmation if it is a bug or not.

Thanks

Comment 2 Daniel Walsh 2010-05-24 15:00:57 UTC
What policy do you have installed?

rpm -q selinux-policy

ls -lZd /var/spool/abrt

The problem is probably this directory is mislabled.  abrt changed the location of the directory from /var/cache to /var/spool. This required a fix to selinux policy to put down the correct label.  Secondarily abrt did not put the /var/spool/abrt directory in the payload.  So rpm did not create the directory at install time with the correct label.  Having an up 2 date policy and abrt package should fix the problem.

Comment 3 Denys Vlasenko 2010-05-24 15:23:06 UTC
Please try this build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2201357

and let me know if it still doesn't work

Comment 4 Denys Vlasenko 2010-05-24 15:23:24 UTC

*** This bug has been marked as a duplicate of bug 593906 ***

Comment 5 GoinEasy9 2010-05-24 17:35:00 UTC
[GoinEasy9@Fedora14dw32 ~]$ rpm -q selinux-policy
selinux-policy-3.7.19-15.fc13.noarch
[GoinEasy9@Fedora14dw32 ~]$ ls -lZd /var/spool/abrt
drwxr-xr-x. abrt abrt system_u:object_r:var_spool_t:s0 /var/spool/abrt

Will try koji build now.

Comment 6 GoinEasy9 2010-05-24 17:58:09 UTC
I already have abrt 1.1.3-1 installed.

[GoinEasy9@Fedora14dw32 ~]$ rpm -q abrt
abrt-1.1.3-1.fc14.i686

Boot log still shows:
Starting abrt daemon: 	[FAILED]

SELinux is preventing /usr/sbin/abrtd "read" access on abrt.
SELinux is preventing /usr/sbin/abrtd "setattr" access on abrt.

I tried rm -r /var/spool/abrt and mkdir /var/spool/abrt
then, restorecon -R -v /var/spool/abrt again with same results.

Comment 7 Daniel Walsh 2010-05-24 18:29:01 UTC
ls -lZd /var/spool/abrt

Could you grab the full avc from /var/log/audit/audit.log

Comment 8 GoinEasy9 2010-05-24 19:34:00 UTC
Created attachment 416205 [details]
/var/log/audit/audit.log

Comment 9 GoinEasy9 2010-05-24 19:34:39 UTC
[GoinEasy9@Fedora14dw32 ~]$ ls -lZd /var/spool/abrt
drwxr-xr-x. root root unconfined_u:object_r:var_spool_t:s0 /var/spool/abrt

Comment 10 Daniel Walsh 2010-05-24 21:26:58 UTC
That is the wrong label.

rpm -q selinux-policy

Comment 11 GoinEasy9 2010-05-24 21:58:52 UTC
[GoinEasy9@Fedora14dw32 ~]$ rpm -q selinux-policy
selinux-policy-3.7.19-15.fc13.noarch

Should I remove /var/spool/abrt and reinstall selinux-policy?

I see the result of ls -lZd /var/spool/abrt has changed from comment 5, possibly because I experimented as I stated at the bottom of comment 6.

Comment 12 atswartz 2010-05-26 16:45:04 UTC
(In reply to comment #11)
> [GoinEasy9@Fedora14dw32 ~]$ rpm -q selinux-policy
> selinux-policy-3.7.19-15.fc13.noarch
> 
> Should I remove /var/spool/abrt and reinstall selinux-policy?
> 
> I see the result of ls -lZd /var/spool/abrt has changed from comment 5,
> possibly because I experimented as I stated at the bottom of comment 6.    

I am having the same problem 
[ats@asus ~]$  rpm -q abrt
abrt-1.1.3-1.fc14.x86_64
[ats@asus ~]$ ls -lZd /var/spool/abrt
drwxr-xr-x. abrt abrt system_u:object_r:var_spool_t:s0 /var/spool/abrt
[ats@asus ~]$ rpm -q selinux-policy
selinux-policy-3.7.19-15.fc13.noarch

Comment 13 atswartz 2010-05-26 16:47:17 UTC
Created attachment 416930 [details]
audit.log

Comment 14 Daniel Walsh 2010-05-26 20:26:24 UTC
Please update to the latest policy in fedora-updates.

Comment 15 atswartz 2010-05-26 23:11:08 UTC
(In reply to comment #14)
> Please update to the latest policy in fedora-updates.    
I had selinux-policy-3.7.19-15.fc13 yum offered me no update so I installed selinux-policy-3.7.19-21.fc13 from koji and abrtd upon reboot.

Comment 16 atswartz 2010-05-26 23:12:59 UTC
EDIT: abrtd started OK upon reboot

Comment 17 GoinEasy9 2010-05-27 01:02:16 UTC
I removed /var/spool/abrt, reinstalled abrt, which resulted in:

[GoinEasy9@Fedora14dw32 ~]$ ls -lZd /var/spool/abrt
drwxr-xr-x. abrt abrt system_u:object_r:var_spool_t:s0 /var/spool/abrt

I then installed selinux-policy-3.7.19-21.fc13 from koji, and the abrtd daemon started after reboot.

Comment 18 Daniel Walsh 2010-05-27 14:23:47 UTC
Can you bump karma on the selinux-policy


Note You need to log in before you can comment on or make changes to this bug.