Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595035 - [abrt] crash in rss-glx-0.9.1.p-2.fc12: _mesa_meta_begin: Process /usr/bin/rss-glx-pixelcity was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in rss-glx-0.9.1.p-2.fc12: _mesa_meta_begin: Process /usr/bin/rs...
Keywords:
Status: CLOSED DUPLICATE of bug 590130
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:6402b31bc5dc7679da983c4696d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-23 01:42 UTC by Sylvain Arth
Modified: 2010-06-16 22:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-16 22:53:49 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-23 01:42 UTC, Sylvain Arth
no flags Details

Description Sylvain Arth 2010-05-23 01:42:43 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: rss-glx-pixelcity -r
component: rss-glx
crash_function: _mesa_meta_begin
executable: /usr/bin/rss-glx-pixelcity
global_uuid: 6402b31bc5dc7679da983c4696d858c72c2c4f0c
kernel: 2.6.32.11-99.fc12.i686.PAE
package: rss-glx-0.9.1.p-2.fc12
rating: 4
reason: Process /usr/bin/rss-glx-pixelcity was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 Sylvain Arth 2010-05-23 01:42:46 UTC
Created attachment 415903 [details]
File: backtrace

Comment 2 Sylvain Arth 2010-06-09 09:48:45 UTC
I think this event is relative to both the gnome-screeensaver and hardware
Fisrt because of the time it happens, very close to the delay set for screen-saving.

Second because it happens not only with "pixelcity" but randomly with some other screensaver displaying sofrwares, mostly (if not only) of the rss-glx family. 

Third because this Linux Box I own is mostly used mostly as a home multipurpose server on the family LAN than as a workbench because built with hardware of the last 90s and early 2000's : Pentim II 400 and Ati Rage Fury128 for example.

I totally agree it's a minor, because :
* without any annoying consequence  (it is totally invisible) for the end user
* probably due to a missing conditional instruction in the code. I rather quite unaware about video hardware but something tells me rss-glx is not embedded feature of my video card (too old) and that's why testers mostly never test the software branch code that my box runs.

Hope this helps

Comment 3 Nils Philippsen 2010-06-11 14:03:08 UTC
Changing component to mesa (assuming it's a software rendering issue).

Comment 4 Jeff Raber 2010-06-16 22:53:49 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 590130 ***


Note You need to log in before you can comment on or make changes to this bug.