Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 595015 - X.org crashes if KMS is disabled and Desktopeffects (kwin) are enabled
Summary: X.org crashes if KMS is disabled and Desktopeffects (kwin) are enabled
Keywords:
Status: CLOSED DUPLICATE of bug 595017
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-22 20:47 UTC by Christian Funke
Modified: 2010-05-22 21:14 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-22 21:14:49 UTC


Attachments (Terms of Use)

Description Christian Funke 2010-05-22 20:47:17 UTC
Description of problem:
If I boot without KMS enabled (i am bitten by bug #581484) and enable desktop effects X.org crashes after a few seconds if I use the desktop normaly. A way to trigger this is to enable the preview windows in the windowlist and then hover the mouse over the taskbar. X.org immediately crashed. I am reporting this on Thinkpad X100e with Radeon 3200 mobility grpahics

Version-Release number of selected component (if applicable):
kdebase-4.4.3-1.fc13

How reproducible:


Steps to Reproduce:
1. Boot system with KMS disabled
2. Enable desktop effects under KDE4
3. Hover the mouse over the windowlist
  
Actual results:
X.org crashes

Expected results:
X.org should not crash and the effects should work appropriately

Additional info:
Other opengl apps seem to be working fine without crashing (tried glxgears and a view video players which use opengl for displaying the video). I will also file a bug against xorg-driver-ati, since I am not sure where the problem lies.

Comment 1 Christian Funke 2010-05-22 20:55:47 UTC
also filed against xorg-x11-drv-ati as bug #595017

If you need any additional info please let me know

Comment 2 Kevin Kofler 2010-05-22 21:14:49 UTC
X crashing == driver bug, sorry.

*** This bug has been marked as a duplicate of bug 595017 ***


Note You need to log in before you can comment on or make changes to this bug.