Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594975 - Preupgrade offers upgrade to Rawhide, but Rawhide install images are no longer provided
Summary: Preupgrade offers upgrade to Rawhide, but Rawhide install images are no longe...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: preupgrade
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-22 12:54 UTC by Frank Murphy
Modified: 2010-08-01 12:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-01 12:19:23 UTC


Attachments (Terms of Use)
data/releases.txt (patch) (deleted)
2010-06-10 13:53 UTC, James Laska
no flags Details | Diff

Description Frank Murphy 2010-05-22 12:54:00 UTC
Description of problem: preupgrade(cli) rawhide 

Version-Release number of selected component (if applicable):
All i686\x86_64


How reproducible: Always since F13-branched

RFE:

Remove "Rawhide" from releases.txt

as it is no longer directly installable:


"The rawhide tree is no longer directly installable.  You have to install a previous release, then enable the rawhide repository and yum update to it."

from an email reply.

Plus all attempts to run preupgrade\cli Rawhide end in failure.

Comment 1 James Laska 2010-06-10 13:53:23 UTC
Created attachment 422909 [details]
data/releases.txt (patch)

The attached patch will adjust the releases.txt file included in preupgrade.  However, I think Fedora infrastructure TRAC ticket#2216 (https://fedorahosted.org/fedora-infrastructure/ticket/2216) will be needed to track updating the official http://mirrors.fedoraproject.org/releases.txt file so that it no longer offers 'Rawhide'.

Does anything else use releases.txt?

Comment 2 Richard Hughes 2010-06-10 14:22:30 UTC
(In reply to comment #1)
> Does anything else use releases.txt?    

PackageKit, but it uses the one shipped in preupgrade.

Richard.

Comment 3 James Laska 2010-06-10 14:47:23 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Does anything else use releases.txt?    
> 
> PackageKit, but it uses the one shipped in preupgrade.

Ah okay.  So I don't know if releases.txt is intended to track "Installable" releases, or just repositories.  I think the former?

How would PackageKit be impacted by removing the 'Rawhide' stanza from releases.txt?

Comment 4 Richard Hughes 2010-06-10 15:40:45 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > (In reply to comment #1)
> > > Does anything else use releases.txt?    
> > 
> > PackageKit, but it uses the one shipped in preupgrade.
> 
> Ah okay.  So I don't know if releases.txt is intended to track "Installable"
> releases, or just repositories.  I think the former?

Correct.

> How would PackageKit be impacted by removing the 'Rawhide' stanza from
> releases.txt?    

Not at all -- the GUI doesn't show unstable releases.

Comment 5 Frank Murphy 2010-06-11 07:16:03 UTC
Removing it from http://mirrors.fedoraproject.org/releases.txt

has now adjusted the behaviour of the GUI, so that even if  "Display unstable" is check Rawhide will not show up.

:)

Comment 6 James Laska 2010-06-11 11:41:17 UTC
(In reply to comment #5)
> Removing it from http://mirrors.fedoraproject.org/releases.txt
> 
> has now adjusted the behaviour of the GUI, so that even if  "Display unstable"
> is check Rawhide will not show up.
> 
> :)    

Hi Frank, I can't tell from your comment if this was a question or not.  But to confirm your findings, the intent of removing 'Rawhide' from http://mirrors.fedoraproject.org/releases.txt is so that it will *not* display as an option in preupgrade.  Rawhide install images are no longer provided

When Fedora 14 is Branched from rawhide, releases.txt will be updated to offer preupgrade -> Fedora 14 (Branched).

Comment 7 Frank Murphy 2010-08-01 12:19:23 UTC
Has been fixed.


Note You need to log in before you can comment on or make changes to this bug.