Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594961 - [abrt] crash in thunderbird-3.0.4-2.fc12: Process /usr/lib64/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in thunderbird-3.0.4-2.fc12: Process /usr/lib64/thunderbird-3.0/...
Keywords:
Status: CLOSED DUPLICATE of bug 570391
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:56ffb383e15fd6943f5813f6f53...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-22 09:54 UTC by Milos Jakubicek
Modified: 2018-04-11 07:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-29 21:43:06 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-22 09:54 UTC, Milos Jakubicek
no flags Details

Description Milos Jakubicek 2010-05-22 09:54:22 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/thunderbird-3.0/thunderbird-bin
component: thunderbird
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib64/thunderbird-3.0/thunderbird-bin
global_uuid: 56ffb383e15fd6943f5813f6f53ef7a8646fe4d5
kernel: 2.6.32.12-115.fc12.x86_64
package: thunderbird-3.0.4-2.fc12
rating: 4
reason: Process /usr/lib64/thunderbird-3.0/thunderbird-bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 Milos Jakubicek 2010-05-22 09:54:26 UTC
Created attachment 415840 [details]
File: backtrace

Comment 2 Chris Campbell 2010-05-23 03:55:23 UTC
#2  <signal handler called>
No symbol table info available.
#3  0x00007f24e3095ce1 in nsSSLThread::requestRecvMsgPeek (si=0x7f24dd5a0400, 
    buf=0x7fff3846712f, amount=1, flags=2, timeout=<value optimized out>)
    at /usr/include/bits/string3.h:52
        threadLock = {<nsAutoLockBase> = {<No data fields>}, mLock = 
    0x7f24e33f53a0, mLocked = 1}
        realSSLFD = <value optimized out>
#4  0x00007f24e30a4074 in PSMRecv (fd=0x7f24d0a99220, 
    buf=<value optimized out>, amount=<value optimized out>, flags=2, 
    timeout=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/security/manager/ssl/src/nsNSSIOLayer.cpp:2038
        locker = {<No data fields>}
        socketInfo = <value optimized out>
#5  0x00007f24fdb6fc02 in nsSocketTransport::IsAlive (this=0x7f24d16c9630, 
    result=0x7fff38467198)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/netwerk/base/src/nsSocketTransport2.cpp:1808
        fd = 0x7f24d0a99220
        c = 0 '\000'
        rval = <value optimized out>



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Matěj Cepl 2010-05-29 21:43:06 UTC

*** This bug has been marked as a duplicate of bug 570391 ***

Comment 4 Matěj Cepl 2010-05-29 21:44:19 UTC
#2  <signal handler called>
No symbol table info available.
#3  0x00007f24e3095ce1 in nsSSLThread::requestRecvMsgPeek (si=0x7f24dd5a0400, 
    buf=0x7fff3846712f, amount=1, flags=2, timeout=<value optimized out>)
    at /usr/include/bits/string3.h:52
        threadLock = {<nsAutoLockBase> = {<No data fields>}, mLock = 
    0x7f24e33f53a0, mLocked = 1}
        realSSLFD = <value optimized out>
#4  0x00007f24e30a4074 in PSMRecv (fd=0x7f24d0a99220, 
    buf=<value optimized out>, amount=<value optimized out>, flags=2, 
    timeout=<value optimized out>)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/security/manager/ssl/src/nsNSSIOLayer.cpp:2038
        locker = {<No data fields>}
        socketInfo = <value optimized out>
#5  0x00007f24fdb6fc02 in nsSocketTransport::IsAlive (this=0x7f24d16c9630, 
    result=0x7fff38467198)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mozilla/netwerk/base/src/nsSocketTransport2.cpp:1808
        fd = 0x7f24d0a99220
        c = 0 '\000'
        rval = <value optimized out>
#6  0x00007f24fe4460c3 in nsImapProtocol::CanHandleUrl (this=0x7f24cdc4e000, 
    aImapUrl=0x7f24be7dc200, aCanRunUrl=0x7fff3846737c, hasToWait=
    0x7fff38467378)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/imap/src/nsImapProtocol.cpp:2081
        isAlive = <value optimized out>
        rv = 0
        isBusy = 0
        isInboxConnection = 0
        curSelectedUrlFolderName = {<nsFixedCString> = {<nsCString> = 
    {<nsACString_internal> = {mData = 0x7fff38467270 "", mLength = 945285100, 
                mFlags = 32767}, <No data fields>}, mFixedCapacity = 
    4221109376, mFixedBuf = 0x67b64b00 <Address 0x67b64b00 out of bounds>}, 
          mStorage = 
    "\000\340\304\315$\177\000\000*Z\311\262<\000\000\000\200\004\231\373$\177\000\000\316\243\242\312<\000\000\000|\251\367K\000\000\000\000\315\311\016\000\000\000\000\000`tF8\377\177\000\000j\022B\376$\177\000"}
        imapState = <value optimized out>
        isSelectedStateUrl = <value optimized out>
        msgUrl = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f24f90e1880}, <No data fields>}
        server = {<nsCOMPtr_base> = {mRawPtr = 
    0x7fff0000003f}, <No data fields>}
        mon = {<nsAutoLockBase> = {<No data fields>}, mLockObject = 
    0x7f24cdc4e000, mLockCount = 1}
        inSelectedState = <value optimized out>
        actionForProposedUrl = <value optimized out>
        pendingUrlFolderName = {<nsFixedCString> = {<nsCString> = 
    {<nsACString_internal> = {mData = 0x7fff38467380 "`", mLength = 
    944141016, mFlags = 32767}, <No data fields>}, mFixedCapacity = 0, 
            mFixedBuf = 0x7f24fe50c4d0 "timeout"}, mStorage = 
    "\000\302}\276$\177\000\000\200sF8\377\177\000\000\004\000\000\000\000\000\000\000\315\275\360\374$\177\000\000PrF8\377\177\000\000D\347W8\377\177\000\000\220rF8\377\177\000\000\000\000\000\000\000\000\000"}
#7  0x00007f24fe42146e in nsImapIncomingServer::GetImapConnection (this=
    0x7f24fb990480, aEventTarget=<value optimized out>, aImapUrl=
    0x7f24be7dc200, aImapConnection=0x7fff38467460)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/imap/src/nsImapIncomingServer.cpp:732
        badConnection = <value optimized out>
        i = 4
        rv = 0
        canRunButBusy = 0
        connection = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f24cdc4e000}, <No data fields>}
        freeConnection = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        isBusy = 0
        isInboxConnection = 0
        requiredState = <value optimized out>
        canRunUrlImmediately = 0
        maxConnections = 5
        cnt = <value optimized out>
        userCancelled = 0
#8  0x00007f24fe421df4 in nsImapIncomingServer::GetImapConnectionAndLoadUrl (
    this=0x7f24fb990480, aClientEventTarget=0x7f2505c48040, aImapUrl=
    0x7f24be7dc200, aConsumer=0x0)
    at /usr/src/debug/thunderbird-3.0.4/comm-1.9.1/mailnews/imap/src/nsImapIncomingServer.cpp:433
        rv = 0
        shuttingDown = 0
        aProtocol = {<nsCOMPtr_base> = {mRawPtr = 0x0}, <No data fields>}
        mailnewsurl = {<nsCOMPtr_base> = {mRawPtr = 
    0x7fff38467500}, <No data fields>}
        accountMgr = {<nsCOMPtr_base> = {mRawPtr = 
    0x7f24fb990060}, <No data fields>}
#9  0x00007f24fe45e659 in nsImapService::GetImapConnectionAndLoadUrl (

Comment 5 Jonathan Larmour 2010-07-15 20:52:45 UTC
This bug is not fixed. I have had the same crash, also with the current thunderbird: thunderbird-3.0.4-2.fc12.x86_64

This bug is marked as a dup of 570391, which is marked as a dup of 579023, which is supposedly fixed by thunderbird-3.0.4-2.fc12.x86_64. So clearly this has been incorrectly identified as a dup. Please reopen!


Note You need to log in before you can comment on or make changes to this bug.