Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594931 - [abrt] crash in openoffice.org-calc-1:3.1.1-19.28.fc12: Window::~Window: Process /usr/lib/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in openoffice.org-calc-1:3.1.1-19.28.fc12: Window::~Window: Proc...
Keywords:
Status: CLOSED DUPLICATE of bug 607286
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f9dc18d51d983d331888f06c8a3...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-22 01:42 UTC by Pancho Delgado
Modified: 2010-06-23 19:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-30 07:41:49 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-22 01:42 UTC, Pancho Delgado
no flags Details

Description Pancho Delgado 2010-05-22 01:42:38 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/openoffice.org3/program/scalc.bin -calc
component: openoffice.org
crash_function: Window::~Window
executable: /usr/lib/openoffice.org3/program/scalc.bin
global_uuid: f9dc18d51d983d331888f06c8a3e44b1dd4278d0
kernel: 2.6.32.11-99.fc12.i686
package: openoffice.org-calc-1:3.1.1-19.28.fc12
rating: 4
reason: Process /usr/lib/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

comment
-----
[xxxxx@xxxxxx ~]$ /usr/lib/openoffice.org3/program/scalc
I/O error : Permission denied
I/O error : Permission denied
[Java framework] Error in function createSettingsDocument (elements.cxx).
javaldx failed! 
/usr/lib/openoffice.org3/program/soffice: line 129: 11828 Segmentation fault      (core dumped) "$sd_prog/$sd_binary" "$@"

How to reproduce
-----
1.Every attempt to start an openoffice app, this occurs
2.
3.

Comment 1 Pancho Delgado 2010-05-22 01:42:46 UTC
Created attachment 415814 [details]
File: backtrace

Comment 2 Caolan McNamara 2010-05-22 07:27:34 UTC
Hmm, all those permission denied warnings, and then a message dialog and a crash. I wonder if your home dir or ~/.openoffice.org config dir is read-only or belongs to someone else ?

Can you do...

echo $HOME > /tmp/out.txt
find $HOME/.openoffice.org -exec ls -asl {} \; >> /tmp/out.txt

and attach out.txt here ?

Comment 3 Caolan McNamara 2010-05-30 07:41:49 UTC
I reckon your ~/.openoffice.org dir belongs to someone else and that's the problem

Comment 4 Caolan McNamara 2010-06-23 19:20:13 UTC

*** This bug has been marked as a duplicate of bug 607286 ***


Note You need to log in before you can comment on or make changes to this bug.