Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594912 - kvm_vm_ioctl_assign_irq() requires CAP_SYS_RAWIO breaking libvirt device assignment
Summary: kvm_vm_ioctl_assign_irq() requires CAP_SYS_RAWIO breaking libvirt device assi...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
high
medium
Target Milestone: beta
: ---
Assignee: Alex Williamson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 22:18 UTC by Alex Williamson
Modified: 2010-11-11 15:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-11 15:43:29 UTC
Target Upstream Version:


Attachments (Terms of Use)
upstream patch backported to rhel6 (deleted)
2010-05-26 19:28 UTC, Alex Williamson
no flags Details | Diff

Description Alex Williamson 2010-05-21 22:18:22 UTC
Description of problem:

kvm_vm_ioctl_assign_irq() checks for CAP_SYS_RAWIO, which is not present for qemu processes launched via libvirt.  This check really isn't necessary since it can only operate on devices previously assigned via the assign_device ioctl.  Remove the check.

Version-Release number of selected component (if applicable):
2.6.32-28.el6

How reproducible:
always

Steps to Reproduce:
1. assign passthrough device via libvirt
2. fail (note this isn't the only problem blocking this path)
3.
  
Actual results:
assign_irq ioctl fails

Expected results:
works

Additional info:

Comment 3 Alex Williamson 2010-05-26 19:28:59 UTC
Created attachment 416999 [details]
upstream patch backported to rhel6

Here's the patch posted to rhkernel-list.  This was accepted upstream.  assign_irq only works on devices already registered through assign_device, so it doesn't make much sense to enforce RAWIO here.

Comment 5 Aristeu Rozanski 2010-05-28 20:38:23 UTC
Patch(es) available on kernel-2.6.32-31.el6

Comment 8 lihuang 2010-08-18 14:09:57 UTC
Tested on  kernel-2.6.32-63.el6
PASS

Comment 9 releng-rhel@redhat.com 2010-11-11 15:43:29 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.