Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594910 - [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib/firefox-3.5/firefox wa...
Keywords:
Status: CLOSED DUPLICATE of bug 592767
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:05a3304a1e0f69f587519252261...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 22:02 UTC by antonio montagnani
Modified: 2010-05-23 03:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-23 03:23:15 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-21 22:02 UTC, antonio montagnani
no flags Details

Description antonio montagnani 2010-05-21 22:02:35 UTC
abrt 1.0.9 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: /usr/lib/firefox-3.5/firefox
component: firefox
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib/firefox-3.5/firefox
global_uuid: 05a3304a1e0f69f587519252261c1e87bd02ed9f
kernel: 2.6.32.12-115.fc12.i686.PAE
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 antonio montagnani 2010-05-21 22:02:38 UTC
Created attachment 415794 [details]
File: backtrace

Comment 2 Chris Campbell 2010-05-23 03:21:09 UTC
#3  <signal handler called>
No symbol table info available.
#4  nsPluginThreadRunnable::nsPluginThreadRunnable (this=0xa8e3d960, instance=
    0x0, func=0x24a8910 <_getString(void*)>, userData=0xa2f182a0)
    at nsNPAPIPlugin.cpp:2468
        lock = {<nsAutoLockBase> = {<No data fields>}, mLock = 0xab665c40, 
          mLocked = 1}
        inst = <value optimized out>
#5  0x070ee2f8 in _pluginthreadasynccall (instance=0x0, func=
    0x24a8910 <_getString(void*)>, userData=0xa2f182a0)
    at nsNPAPIPlugin.cpp:2514
No locals.
#6  0x024a96d3 in PluginRequestProcessor::sendString (this=0xaa7437c8, 
    message_parts=0xaa494a40)
    at /usr/src/debug/icedtea6-1.8/plugin/icedteanp/IcedTeaPluginRequestProcessor.cc:394
        java_request = {<BusSubscriber> = {_vptr.BusSubscriber = 0x24ba4f8}, 
          instance = -1461463156, reference = 12718529, result_ready = false, 
          result = 0xa8c1fa40}
        reference = 1113
        thread_data = {parameters = std::vector of length 2, capacity 2 = {
    0x0, 0xa9f9a7a0}, result = "", result_ready = false, call_successful = 
    false}
        variant_ptr = "2851710880"
        response = ""
        instance = 0x0
#7  0x024abc63 in queue_processor (data=0xaa7437c8)
    at /usr/src/debug/icedtea6-1.8/plugin/icedteanp/IcedTeaPluginRequestProcessor.cc:735
        message_parts = 0xaa494a40
        command = "ToString"
        wait_mutex = {__data = {__lock = 2, __count = 0, __owner = 7090, 
            __kind = 0, __nusers = 0, {__spins = 0, __list = {__next = 
    0x0}}}, __size = 
    "\002\000\000\000\000\000\000\000\262\033", '\000' <repeats 13 times>, 
          __align = 2}
#8  0x00378ab5 in start_thread (arg=0xa2f18b70) at pthread_create.c:297
        __res = <value optimized out>
        __ignore1 = 3
        __ignore2 = 0
        pd = 0xa2f18b70
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {3710964, 0, 4001536, 
    -1561230216, -1122335344, 822652629}, mask_was_saved = 0}}, priv = {pad = 
    {0x0, 0x0, 0x0, 0x0}, data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        pagesize_m1 = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#9  0x002a4d8e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
No locals.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Chris Campbell 2010-05-23 03:23:15 UTC
Thank you for taking the time to submit this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 592767 ***


Note You need to log in before you can comment on or make changes to this bug.