Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594790 - X doesn't start with Arrandale Graphics Chipset
Summary: X doesn't start with Arrandale Graphics Chipset
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-intel
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Adam Jackson
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 16:04 UTC by Andreas Petzold
Modified: 2010-05-24 14:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-24 14:06:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
Xorg.0.log (deleted)
2010-05-21 16:04 UTC, Andreas Petzold
no flags Details

Description Andreas Petzold 2010-05-21 16:04:30 UTC
Created attachment 415723 [details]
Xorg.0.log

Description of problem:
X doesn't start on a Fujitsu Q9000 with integrated Intel Graphics when using the intel driver.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.10.0-4.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Delete xorg.conf, or create xorg.conf with intel driver
2. Try to start X
3.
  
Actual results:
X doesn't start

Expected results:
X starts

Additional info:

Works with vesa driver.

Hardware:
lspci -v
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 12) (prog-if 00 [VGA controller])

lspci -n
00:02.0 0300: 8086:0046 (rev 12)

Comment 2 Andreas Petzold 2010-05-21 16:16:27 UTC
I should have studied the Xorg log more carefully. Looks like X didn't find any output device:

(WW) intel(0): No outputs definitely connected, trying again...
(II) intel(0): Output VGA1 disconnected
(II) intel(0): Output HDMI1 disconnected
(II) intel(0): Output HDMI2 disconnected
(WW) intel(0): Unable to find initial modes
(EE) intel(0): No modes.
(II) UnloadModule: "intel"
(EE) Screen(s) found, but none have a usable configuration.

My monitor was connected vie a DVI-to-VGA adapter. All is fine when directly using DVI.

I'm closing this now, since it's not a bug.

Comment 3 Adam Jackson 2010-05-24 14:06:32 UTC
Closing per comment #2.


Note You need to log in before you can comment on or make changes to this bug.