Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594693 - ypbind probes for the fastest server too often
Summary: ypbind probes for the fastest server too often
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ypbind
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Karel Klíč
QA Contact: Alex Sersen
URL:
Whiteboard:
Depends On: 594668
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 11:01 UTC by Karel Klíč
Modified: 2013-11-01 01:33 UTC (History)
5 users (show)

Fixed In Version: ypbind-1.20.4-24.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 594668
Environment:
Last Closed: 2010-11-10 22:00:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Karel Klíč 2010-05-21 11:01:11 UTC
+++ This bug was initially created as a clone of Bug #594668 +++

Description of problem:
The ypbind manual page says that it checks the current server every 20s to confirm it is up, and also pings all configured servers every 15 minutes to check on which is currently the fastest to respond. In fact it pings the servers every minute which may cause ypbind to flip the servers very often.

Version-Release number of selected component (if applicable):
ypbind-1.19-12

How reproducible:
Always

Steps to Reproduce:
1. configure ypbind to try to contact more servers, i.e. add two servers to /etc/yp.conf (one of them must be reachable):

ypserver 192.168.1.1
ypserver 192.168.1.2

2. start ypbind in the debug mode

ypbind -debug

3. it logs out the pings of the servers
  
Actual results:
The "Check new for fastest server." logs appear every minute:

Expected results:
The "Check new for fastest server" logs appear every 15 minutes (as documented)

Additional info:
This seems to be caused by the ypbind-mt-1.19-log-binds.patch which contains the following chunk:
@@ -1031,7 +1067,8 @@ test_bindings (void *param __attribute__
      pthread_exit (&success);

     lastcheck += ping_interval;
-      if (lastcheck >= 900) /* 900 = 15min. */
+      //if (lastcheck >= 900) /* 900 = 15min. */
+      if (lastcheck >= 60) /* 900 = 15min. */

At the first glance it looks like this has been added for the debugging purposes to test the patch for the bug #198689.  We should revert this part or explain why does the interval have to be shortened this much and fix the documentation.

--- Additional comment from kklic@redhat.com on 2010-05-21 06:55:09 EDT ---

Correct, it seems it was added for debugging purposes.
The limit should be set back to 900.

Comment 2 RHEL Product and Program Management 2010-05-21 12:55:57 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 releng-rhel@redhat.com 2010-11-10 22:00:14 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.