Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594660 - glibc not compatible with Cyrix M II
Summary: glibc not compatible with Cyrix M II
Keywords:
Status: CLOSED DUPLICATE of bug 579838
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 09:26 UTC by Andre Robatino
Modified: 2010-06-13 09:32 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-10 09:01:05 UTC


Attachments (Terms of Use)

Description Andre Robatino 2010-05-21 09:26:51 UTC
Description of problem:
Shortly after booting the Fedora 13 i386 DVD (formerly RC3) and selecting the first menu option, there is a kernel panic.  The following is what appears on the screen:

Initalizing network drop monitor service
Freeing unused kernel memory: 468k freed
Write protecting the kernel text: 3544k
Write protecting the kernel read-only data: 1740k
Kernel panic - not syncing: Attempted to kill init!
Pid: 1, comm: init Not tainted 2.6.33.3-85.fc13.i686 #1
Call trace:
 [<c076eab3>] ? printk+0xf/0x14
 [<c076e9f1>] panic+0x39/0xec
 [<c0439fd4>] do_exit+0x5d/0x615
 [<c04433d4>] ? __sigqueue_free+0x2d/0x30
 [<c0443762>] ? __dequeue_signal+0xd6/0xfe
 [<c0445747>] ? dequeue_signal+0xb1/0x120
 [<c043a5f7>] do_group_exit+0x6b/0x94
 [<c0445b24>] get_signal_to_deliver+0x36e/0x389
 [<c0403f62>] ? do_invalid_op+0x0/0x80
 [<c04026d4>] do_signal+0x5a/0x6f4
 [<c044521f>] ? force_sig_info+0x9d/0xa7
 [<c04d03a3>] ? putname+0x25/0x2e
 [<c0408b4d>] ? sys_execve+0x46/0x4f
 [<c0773084>] ? do_page_fault+0x2cd/0x2fa
 [<c0403f62>] ? do_invalid_op+0x0/0x80
 [<c0402d8d>] do_notify_resume+0x1f/0x79
 [<c0770c14>] work_notifysig+0x13/0x1b

Version-Release number of selected component (if applicable):
Whatever the F13 release version of anaconda is

How reproducible:
always

Additional info:

Smolt URL of affected machine:

http://www.smolts.org/client/show/pub_7982b3d7-a650-4770-8128-d385918bf9bd

This is a very old machine, but before now (up to and including F12) it has always been able to boot the i386 DVD.  I tried the F13 netinst image burned to a CD-R but the same thing happens.  I can boot the machine into F11 (its current OS) and use "checkisomd5 --verbose /dev/cdrom" to verify that the machine can read the discs properly.

Comment 1 Andre Robatino 2010-05-25 21:10:56 UTC
Same exact kernel panic (even the addresses) when booting the F13 i386 installer from the BFO ISO from http://bfo.fedoraproject.org.

Comment 2 Andre Robatino 2010-05-25 21:11:48 UTC
Sorry, URL should be http://boot.fedoraproject.org.

Comment 3 Andre Robatino 2010-06-03 13:33:06 UTC
Machine is now running F12, Smolt URL is

http://www.smolts.org/client/show/pub_49b32bf0-4174-4537-bd84-37fc4aa1c614

Comment 4 Andre Robatino 2010-06-07 02:50:45 UTC
Heard that some CPUs are no longer supported in F13.  In case it helps to determine whether that's the problem here, below is /proc/cpuinfo output.

processor	: 0
vendor_id	: CyrixInstead
cpu family	: 6
model		: 2
model name	: M II 3x Core/Bus Clock
stepping	: 4
cpu MHz		: 250.027
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu de tsc msr cx8 pge cmov mmx cyrix_arr up
bogomips	: 500.05
clflush size	: 32
cache_alignment	: 32
address sizes	: 32 bits physical, 32 bits virtual
power management:

Comment 5 Andre Robatino 2010-06-09 19:30:18 UTC
After looking at bug #579838 and doing some reading, I suspect that the reason for the panic is the same as that for the Geode LX (based on the do_invalid_op).  If this is not the case, I'll set the Component back to the kernel where it was originally.

Comment 6 Andreas Schwab 2010-06-10 07:40:01 UTC
A kernel panic can never be a glibc bug.

Comment 7 Andre Robatino 2010-06-10 07:52:08 UTC
OK, I may have misunderstood the significance of the following from the first comment in the other bug:

> The symptoms are
> - when booted F-13 kernel + F-13 initramfs => kernel panic when code from
> initramfs should be executed

If this is correct, someone please confirm (Andreas is no longer on the CC list) and I'll switch the component back to the kernel.

Comment 8 Andre Robatino 2010-06-10 07:57:51 UTC
Never mind, it's already switched.

Comment 9 Andreas Schwab 2010-06-10 09:01:05 UTC

*** This bug has been marked as a duplicate of bug 579838 ***

Comment 10 Andre Robatino 2010-06-13 09:32:32 UTC
The same issue appears to affect Fedora-13-i686-Live.iso (but I only get a one-line kernel panic message, not the full call trace).


Note You need to log in before you can comment on or make changes to this bug.