Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594611 - file cannot recognize SQL scripts
Summary: file cannot recognize SQL scripts
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: file
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jan Kaluža
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 07:41 UTC by Milos Malik
Modified: 2012-08-07 05:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-07 05:25:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Milos Malik 2010-05-21 07:41:51 UTC
Description of problem:


Version-Release number of selected component (if applicable):
file-5.04-4.el6
postgresql-contrib-8.4.4-1.el6.i686
postgresql-server-8.4.4-1.el6.i686
postgresql-test-8.4.4-1.el6.i686

How reproducible:
always

Steps to Reproduce:
# rpm -ql postgresql-contrib postgresql-server postgresql-test | grep '\.sql' | xargs file
/usr/share/pgsql/contrib/_int.sql:                         ASCII C program text
/usr/share/pgsql/contrib/adminpack.sql:                    ASCII C program text
/usr/share/pgsql/contrib/autoinc.sql:                      ASCII C program text
/usr/share/pgsql/contrib/btree_gin.sql:                    ASCII C program text
/usr/share/pgsql/contrib/btree_gist.sql:                   ASCII C program text
/usr/share/pgsql/contrib/chkpass.sql:                      ASCII C program text
/usr/share/pgsql/contrib/citext.sql:                       ASCII C program text
/usr/share/pgsql/contrib/cube.sql:                         ASCII C program text
/usr/share/pgsql/contrib/dblink.sql:                       ASCII C program text
/usr/share/pgsql/contrib/dict_int.sql:                     ASCII C program text
/usr/share/pgsql/contrib/dict_xsyn.sql:                    ASCII C program text
/usr/share/pgsql/contrib/earthdistance.sql:                ASCII C program text
/usr/share/pgsql/contrib/fuzzystrmatch.sql:                ASCII C program text
/usr/share/pgsql/contrib/hstore.sql:                       ASCII C program text
/usr/share/pgsql/contrib/insert_username.sql:              ASCII C program text
/usr/share/pgsql/contrib/int_aggregate.sql:                ASCII C program text
/usr/share/pgsql/contrib/isn.sql:                          ASCII C program text
/usr/share/pgsql/contrib/lo.sql:                           ASCII C program text
/usr/share/pgsql/contrib/ltree.sql:                        ASCII C program text
/usr/share/pgsql/contrib/moddatetime.sql:                  ASCII C program text
/usr/share/pgsql/contrib/pageinspect.sql:                  ASCII C program text
/usr/share/pgsql/contrib/pg_buffercache.sql:               ASCII C program text
/usr/share/pgsql/contrib/pg_freespacemap.sql:              ASCII C program text
...

Comment 1 RHEL Product and Program Management 2010-05-21 07:55:53 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 RHEL Product and Program Management 2011-07-05 23:46:21 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 9 Suzanne Yeghiayan 2012-01-31 21:17:02 UTC
This request was evaluated by Red Hat Product Management for inclusion in the
current release of Red Hat Enterprise Linux. Because the affected component is
not scheduled to be updated in the current release, Red Hat is unfortunately
unable to address this request at this time.  It has been proposed for the next
release. If you would like it considered as an exception in the current
release, please ask your support representative.

Comment 10 Jan Kaluža 2012-08-07 05:25:10 UTC
I don't see reliable way how to detect SQL and don't break detection of other files which include just few SQL statements. It's not possible to do that with File if we would not consider adding specific parser in C just for SQL, which is not possible right now.


Note You need to log in before you can comment on or make changes to this bug.