Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594605 - file cannot recognize perl modules and perl documentation
Summary: file cannot recognize perl modules and perl documentation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: file
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Kaluža
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-21 07:09 UTC by Milos Malik
Modified: 2010-11-10 20:23 UTC (History)
1 user (show)

Fixed In Version: file-5.04-5.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 20:23:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
Fix for regressions (deleted)
2010-06-11 10:55 UTC, Jan Kaluža
no flags Details | Diff

Description Milos Malik 2010-05-21 07:09:24 UTC
Description of problem:
Some .pm and .pod files are not correctly recognized by file. I believe it's a regression because file-5.03-12.el6 recognizes them correctly.

Version-Release number of selected component (if applicable):
file-5.04-4.el6.i686
perl-5.10.1-109.el6.i686
perl-DBI-1.609-4.el6.i686
perl-HTML-Parser-3.64-2.el6.i686
perl-libwww-perl-5.833-2.el6.noarch
perl-Pod-Simple-3.13-109.el6.i686
perl-Test-Harness-3.17-109.el6.i686
perl-MailTools-2.04-4.el6.noarch
spamassassin-3.3.1-2.el6.i686

How reproducible:
always

Steps to Reproduce:
* pick any of these files and run file on it
/usr/lib/perl5/DBI/FAQ.pm
/usr/lib/perl5/HTML/Filter.pm
/usr/lib/perl5/HTML/HeadParser.pm
/usr/lib/perl5/HTML/LinkExtor.pm
/usr/lib/perl5/HTML/Parser.pm
/usr/lib/perl5/HTML/PullParser.pm
/usr/lib/perl5/HTML/TokeParser.pm
/usr/share/perl5/HTML/Form.pm
/usr/share/perl5/HTTP/Headers/Util.pm
/usr/share/perl5/Locale/Script.pod
/usr/share/perl5/LWP/Protocol/file.pm
/usr/share/perl5/LWP/Protocol/gopher.pm
/usr/share/perl5/Mail/Header.pod
/usr/share/perl5/Mail/Internet.pod
/usr/share/perl5/Mail/SpamAssassin/Plugin/MIMEHeader.pm
/usr/share/perl5/Pod/Find.pm
/usr/share/perl5/Pod/Html.pm
/usr/share/perl5/pod/perl5004delta.pod
/usr/share/perl5/pod/perl572delta.pod
/usr/share/perl5/pod/perlpod.pod
/usr/share/perl5/Pod/Select.pm
/usr/share/perl5/Pod/Simple/HTMLBatch.pm
/usr/share/perl5/Pod/Simple/HTML.pm
/usr/share/perl5/Pod/Simple/Subclassing.pod
/usr/share/perl5/Pod/Simple/XHTML.pm
/usr/share/perl5/TAP/Formatter/Console/ParallelSession.pm
/usr/share/perl5/TAP/Formatter/Session.pm

Actual results:
you will see messages like "HTML document text"

Expected results:
you will see messages like "Perl5 module source text" or "Perl POD document text"

Comment 3 Jan Kaluža 2010-06-11 10:55:40 UTC
Created attachment 423237 [details]
Fix for regressions

Attached patch fixes regressions in file-5.0.4 which are causing described
problem. It basically removes excessive HTML/SGML "magic patterns".

Comment 6 Jan Kaluža 2010-06-11 11:44:26 UTC
Commited to CVS, fixed in version file-5.04-5.el6.

http://post-office.corp.redhat.com/archives/cvs-commits-list/2010-June/msg01612.html

Comment 8 releng-rhel@redhat.com 2010-11-10 20:23:14 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.