Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594485 - clvmd segfault when reconfiguring storage with clvmd running
Summary: clvmd segfault when reconfiguring storage with clvmd running
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: LVM and device-mapper development team
QA Contact: Corey Marthaler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 19:56 UTC by Corey Marthaler
Modified: 2010-06-07 13:57 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-07 13:57:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Corey Marthaler 2010-05-20 19:56:27 UTC
Description of problem:
I was attempting to dice up storage inorder to run basic tests and clvmd died.

clvmd[2176]: segfault at 30 ip 000000000041a63d sp 00007f16871ae800 error]

7 disk(s) to be used:                                                                                    
        taft-01=/dev/sdb /dev/sdc /dev/sdd /dev/sde /dev/sdf /dev/sdg /dev/sdh                           
        taft-02=/dev/sdb /dev/sdc /dev/sdd /dev/sde /dev/sdf /dev/sdg /dev/sdh                           
        taft-03=/dev/sdb /dev/sdc /dev/sdd /dev/sde /dev/sdf /dev/sdg /dev/sdh                           
        taft-04=/dev/sdb /dev/sdc /dev/sdd /dev/sde /dev/sdf /dev/sdg /dev/sdh                           

on taft-01...
dicing /dev/sdb into 1... 
dicing /dev/sdc into 1... 
dicing /dev/sdd into 1... 
dicing /dev/sde into 1... 
dicing /dev/sdf into 1... 
dicing /dev/sdg into 1... 
dicing /dev/sdh into 1... 
re-reading disks on taft-03...
re-reading disks on taft-01...
re-reading disks on taft-02...
re-reading disks on taft-04...
Zeroing out the new partitions.../dev/sdb1.../dev/sdc1.../dev/sdd1.../dev/sde1.../dev/sdf1.../dev/sdg1.../dev/sdh1...                                                                                             
Reload the device cache on all nodes...                                                                  
connect() failed on local socket: Connection refused                                                     
*** glibc detected *** clvmd: free(): invalid pointer: 0x0000000000464474 ***                            
======= Backtrace: =========                                                                             
/lib64/libc.so.6[0x3902a75746]                                                                           
clvmd[0x414014]                                                                                          
clvmd(refresh_clvmd+0x137)[0x4149a7]                                                                     
clvmd(main+0x15a)[0x41133a]                                                                              
/lib64/libc.so.6(__libc_start_main+0xfd)[0x3902a1ec5d]                                                   
clvmd[0x40e529]                                                                                          
======= Memory map: ========                                                                             
00400000-00484000 r-xp 00000000 fd:00 139277                             /usr/sbin/clvmd                 
00683000-00686000 rw-p 00083000 fd:00 139277                             /usr/sbin/clvmd                 
00686000-0068e000 rw-p 00000000 00:00 0                                                                  
00885000-0088a000 rw-p 00085000 fd:00 139277                             /usr/sbin/clvmd                 
020c0000-020e1000 rw-p 00000000 00:00 0                                  [heap]                          
[...]


Version-Release number of selected component (if applicable):
2.6.32-25.el6.x86_64

lvm2-2.02.65-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
lvm2-libs-2.02.65-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
lvm2-cluster-2.02.65-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-libs-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-event-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
device-mapper-event-libs-1.02.48-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010
cmirror-2.02.65-1.el6    BUILT: Tue May 18 04:46:06 CDT 2010

Comment 1 Christine Caulfield 2010-05-21 09:17:33 UTC
Is there a core or a trace from clvmd daemon itself? That backtrace is from the command-line clvmd failing to connect to the daemon.

Comment 2 Milan Broz 2010-06-07 13:57:06 UTC
Closing this ad dup of bug #574595 (the same backtrace), but maybe there is another problem which kills clvmd before.

*** This bug has been marked as a duplicate of bug 574595 ***


Note You need to log in before you can comment on or make changes to this bug.