Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594475 - breaks yum upgrade due to dependent file move
Summary: breaks yum upgrade due to dependent file move
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libguestfs
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 19:21 UTC by Bill Nottingham
Modified: 2014-03-17 03:23 UTC (History)
4 users (show)

Fixed In Version: libguestfs-1.2.8-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-27 18:32:55 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2010-05-20 19:21:49 UTC
Description of problem:

[root@nostromo ~]# yum upgrade
Loaded plugins: auto-update-debuginfo, refresh-packagekit
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package openssl.i686 0:1.0.0-4.fc13 set to be updated
---> Package openssl.x86_64 0:1.0.0-4.fc13 set to be updated
---> Package openssl-devel.x86_64 0:1.0.0-4.fc13 set to be updated
--> Processing Dependency: /usr/lib64/.libcrypto.so.1.0.0.hmac for package: 1:libguestfs-1.2.7-2.fc13.x86_64
--> Processing Dependency: /usr/lib64/.libcrypto.so.10.hmac for package: 1:libguestfs-1.2.7-2.fc13.x86_64
--> Processing Dependency: /usr/lib64/libcrypto.so.10 for package: 1:libguestfs-1.2.7-2.fc13.x86_64
--> Finished Dependency Resolution
Error: Package: 1:libguestfs-1.2.7-2.fc13.x86_64 (@updates-testing)
           Requires: /usr/lib64/libcrypto.so.10
           Removing: openssl-1.0.0-1.fc13.x86_64 (@fedora)
Error: Package: 1:libguestfs-1.2.7-2.fc13.x86_64 (@updates-testing)
           Requires: /usr/lib64/.libcrypto.so.1.0.0.hmac
           Removing: openssl-1.0.0-1.fc13.x86_64 (@fedora)
Error: Package: 1:libguestfs-1.2.7-2.fc13.x86_64 (@updates-testing)
           Requires: /usr/lib64/.libcrypto.so.10.hmac
           Removing: openssl-1.0.0-1.fc13.x86_64 (@fedora)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

libcrypto, and the associated hmac files, moved to /lib|/lib64. libguestfs therefore has broken deps, and needs upgraded.

Version-Release number of selected component (if applicable):

libguestfs-1.2.7-2.fc13.x86_64

How reproducible:

100%

Steps to Reproduce:
1. enable F13 updates testing
2. try to upgrade

Comment 1 Richard W.M. Jones 2010-05-20 20:35:24 UTC
I've kicked off a rebuild here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2200067

Comment 2 Bill Nottingham 2010-05-20 21:11:57 UTC
Just remembered - due to the new openssl being in updates-testing, not updates, it's not going to be in the buildroot by default. Not sure whether that affects the libguestfs build process.

Comment 3 Richard W.M. Jones 2010-05-20 21:37:03 UTC
I opened this rel-eng ticket:
https://fedorahosted.org/rel-eng/ticket/3751

Comment 4 Richard W.M. Jones 2010-05-21 06:57:18 UTC
Another rebuild now going here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2200571

Comment 5 Fedora Update System 2010-05-21 11:33:45 UTC
libguestfs-1.2.7-2.fc13.1 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.2.7-2.fc13.1

Comment 6 Fedora Update System 2010-05-22 01:49:30 UTC
libguestfs-1.2.7-2.fc13.1 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libguestfs-1.2.7-2.fc13.1

Comment 7 Fedora Update System 2010-05-24 18:06:41 UTC
libguestfs-1.2.8-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/libguestfs-1.2.8-1.fc13

Comment 8 Fedora Update System 2010-05-25 18:37:14 UTC
libguestfs-1.2.8-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/libguestfs-1.2.8-1.fc13

Comment 9 Fedora Update System 2010-05-27 18:32:48 UTC
libguestfs-1.2.8-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.