Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594455 - SSM package upgrade doesn't handle systems in different channels properly
Summary: SSM package upgrade doesn't handle systems in different channels properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 530
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Stephen Herr
QA Contact: Dimitar Yordanov
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage 1116390
TreeView+ depends on / blocked
 
Reported: 2010-05-20 17:51 UTC by Justin Sherrill
Modified: 2018-12-06 14:35 UTC (History)
16 users (show)

Fixed In Version: spacewalk-java-2.0.2-76-sat
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1116390 (view as bug list)
Environment:
Last Closed: 2014-07-04 13:26:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 655073 None None None Never
Red Hat Product Errata RHBA-2014:0807 normal SHIPPED_LIVE cobbler and spacewalk bug fix update 2014-06-30 18:09:37 UTC

Description Justin Sherrill 2010-05-20 17:51:04 UTC
Description of problem:

The ssm package upgrade page doesn't handle properly systems that are in different channels that have different package sets.

The result is that you can only install packages on the systems that have the newest packages of the group.  For example:


1.  select a RHEL 5 and a RHEL 4 system that both need kernel updates.
2.  Go to the SSm package upgrade screen
3.  select a RHEL 5 kernel as well as a RHEL 4 kernel
4.  Hit the "Upgrade selected packages" button

Results:

 Only the RHEL 5 version is selected 



Basically the page is getting the Max evr of every package name on the page and then only showing the systems that need that max version (so systems that only need an older version are excluded).

It's pretty broken and will pretty much take re-writing all of the logic of the page to fix :/

Comment 2 Justin Sherrill 2010-05-21 13:56:18 UTC
Hey Cliff,

Yeah, It can probably be moved to Sat 6.0 unless customers start complaining about it (which i would expect sooner or later).  I'd say probably 3 days to fix it.  

-Justin

Comment 3 Clifford Perry 2010-06-02 18:01:56 UTC
We should try and get this in 5.3 Errata, lower priority (no customers noticed/complain (yet)) - if not, make sure it is in Galactica. Leaving on sat531-triage for now. 

Cliff

Comment 15 Stephen Herr 2014-05-09 21:26:23 UTC
Committing to Spacewalk master:
58e644c846f988517036d3cd29bc609aa00a5786
1695076e6bfe5c4c51c9a3f824bb1c3dea010d52

Comment 21 Stephen Herr 2014-06-05 12:36:24 UTC
Also need another Spacewalk master commit to fix db error:
e536f11d606d4f4a7c2370a4fbf7d8724c794e62

Comment 24 Stephen Herr 2014-06-05 15:15:33 UTC
The elaborator also needs a GROUP BY fix:
09481d3199e90039089ffa7711dbacda3afbc8ac

Comment 28 errata-xmlrpc 2014-06-30 14:10:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0807.html

Comment 32 Milan Zázrivec 2014-07-04 13:26:18 UTC
The problem described in comment #29 will further be tracked in bug
https://bugzilla.redhat.com/show_bug.cgi?id=1116390 and it will be
fixed with a new Satellite 5.6 errata.

This bug report will be closed again, since it has already been closed
with a released errata and we can no longer use it for discussing
new issues, regressions, etc.

Comment 33 Clifford Perry 2014-07-07 13:21:11 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1116390

errata-xmlrpc <errata-xmlrpc@redhat.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RELEASE_PENDING             |CLOSED
         Resolution|---                         |ERRATA
        Last Closed|                            |2014-07-07 09:18:50



--- Comment #7 from errata-xmlrpc <errata-xmlrpc@redhat.com> ---
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0841.html


Note You need to log in before you can comment on or make changes to this bug.