Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594430 - Gwibber does not start
Summary: Gwibber does not start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gwibber
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 16:13 UTC by Aioanei Rares
Modified: 2010-08-20 02:10 UTC (History)
1 user (show)

Fixed In Version: gwibber-2.31.4-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-20 01:55:43 UTC


Attachments (Terms of Use)

Description Aioanei Rares 2010-05-20 16:13:25 UTC
Description of problem:

After installing it, I start gwibber and it asks me top set up a keyring password
(this is KDE); after that, and subsequent starts, nothing happens. 

Version-Release number of selected component (if applicable):

gwibber-2.30.0.1-6.fc14.noarch

How reproducible:

Everytime

Steps to Reproduce:
1.start gwibber
2.
3.
  
Actual results:

None but a traceback (below)

Expected results:

gwibber

Additional info:


$ gwibber
Removing stale, deceptive pid file.
Apache CouchDB has started, time to relax.
Browse your desktop CouchDB at file:///home/arares/.local/share/desktop-couch/couchdb.html
Traceback (most recent call last):
  File "/usr/bin/gwibber", line 67, in <module>
    client.Client()
  File "/usr/lib/python2.6/site-packages/gwibber/client.py", line 459, in __init__
    self.w = GwibberClient()
  File "/usr/lib/python2.6/site-packages/gwibber/client.py", line 28, in __init__
    self.model = gwui.Model()
  File "/usr/lib/python2.6/site-packages/gwibber/gwui.py", line 42, in __init__
    self.settings = util.SettingsMonitor()
  File "/usr/lib/python2.6/site-packages/gwibber/util.py", line 91, in __init__
    DEFAULT_SETTINGS)
  File "/usr/lib/python2.6/site-packages/gwibber/microblog/util/couch.py", line 65, in __init__
    self.database = CouchDatabase(dbname, create=True)
  File "/usr/lib/python2.6/site-packages/desktopcouch/records/server.py", line 57, in __init__
    server_class=server_class, oauth_tokens=oauth_tokens, ctx=ctx)
  File "/usr/lib/python2.6/site-packages/desktopcouch/records/server_base.py", line 147, in __init__
    if database not in self._server:
  File "/usr/lib/python2.6/site-packages/couchdb/client.py", line 120, in __contains__
    self.resource.head(validate_dbname(name))
  File "/usr/lib/python2.6/site-packages/couchdb/client.py", line 1019, in head
    return self._request('HEAD', path, headers=headers, **params)
  File "/usr/lib/python2.6/site-packages/couchdb/client.py", line 1073, in _request
    raise ServerError((status_code, error))
couchdb.client.ServerError: (500, '')

Since I never got to setup any accounts, why would any server respond with 500?

Comment 1 Fedora Update System 2010-07-26 19:21:35 UTC
gwibber-2.31.2-7.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gwibber-2.31.2-7.fc12

Comment 2 Fedora Update System 2010-07-26 19:29:15 UTC
gwibber-2.31.2-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gwibber-2.31.2-7.fc13

Comment 3 Fedora Update System 2010-07-27 02:25:27 UTC
gwibber-2.31.2-7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gwibber-2.31.2-7.fc13

Comment 4 Fedora Update System 2010-07-27 02:30:30 UTC
gwibber-2.31.2-7.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gwibber-2.31.2-7.fc12

Comment 5 Bug Zapper 2010-07-30 11:40:02 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 6 Fedora Update System 2010-08-09 20:26:21 UTC
gwibber-2.31.4-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc12

Comment 7 Fedora Update System 2010-08-09 20:31:15 UTC
gwibber-2.31.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc13

Comment 8 Fedora Update System 2010-08-10 21:28:15 UTC
gwibber-2.31.4-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc12

Comment 9 Fedora Update System 2010-08-10 21:33:44 UTC
gwibber-2.31.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gwibber'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/gwibber-2.31.4-1.fc13

Comment 10 Fedora Update System 2010-08-20 01:50:48 UTC
gwibber-2.31.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-08-20 02:05:24 UTC
gwibber-2.31.4-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.