Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594412 - service abrtd status incorrectly reports abrt is stopped
Summary: service abrtd status incorrectly reports abrt is stopped
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jiri Moskovcak
QA Contact: Michal Nowak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 15:33 UTC by Marc Milgram
Modified: 2015-02-01 22:52 UTC (History)
8 users (show)

Fixed In Version: abrt-1.1.2-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-02 18:47:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
Suggested patch (deleted)
2010-05-20 18:49 UTC, Marc Milgram
no flags Details | Diff

Description Marc Milgram 2010-05-20 15:33:26 UTC
Description of problem:
# service abrtd status shows that abrt is stopped even when it is running.

Version-Release number of selected component (if applicable):
abrt-1.1.2-1.el6.x86_64


How reproducible:
Every time

Steps to Reproduce:
1. Start abrtd (service abrtd start)
2. Check the status (service abrtd status)
3. Verify the status (ps -ef | grep abrtd)
  
Actual results:
service abrtd status show that abrtd is stopped, but ps -ef | grep abrtd shows that it is running.

Expected results:
service abrtd status agrees with ps -ef.


Additional info:

Comment 1 RHEL Product and Program Management 2010-05-20 17:46:41 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Denys Vlasenko 2010-05-20 18:17:03 UTC
Can't reproduce:

# service abrtd status
abrtd (pid  1724) is running...
# service abrtd stop
Stopping abrt daemon:                                      [  OK  ]
# service abrtd status
abrtd is stopped
# ps -ef | grep abrtd
root     10144 10012  0 20:16 pts/3    00:00:00 grep abrtd

Comment 3 Marc Milgram 2010-05-20 18:49:05 UTC
Created attachment 415490 [details]
Suggested patch

This fails every time with me.  /etc/init.d/abrtd calls "status abrt" but should call "status abrtd".

The included patch should fix the problem.

Comment 7 releng-rhel@redhat.com 2010-07-02 18:47:47 UTC
Red Hat Enterprise Linux Beta 2 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.