Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5944 - Exception error in installing RedHat 6.1
Summary: Exception error in installing RedHat 6.1
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 1999-10-14 10:35 UTC by khafagy
Modified: 2008-05-01 15:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 1999-11-30 18:46:43 UTC

Attachments (Terms of Use)

Description khafagy 1999-10-14 10:35:16 UTC

I am installing redhat6.1 from harddrive and I am using the
boot.img (local boot diskette) for booting, I have the
following error:

- In the Reading package information phase during the
installation (after specifying upgrade installation class)
I got the following "exception error" which can not be

Trace back (innermost last):

file "/usr/bin/anaconda.real", line 225 in ?
intforun (todo, test=test)

file "/tmp/lib/python1.5/site-packages/", line 1000,
in run rc = apply (step[1](), step[2])

file "/tmp/lib/python1.5/site-packages/", line 251,
in --call-- todo.upgradefindpackage (root)

file "/tmp/lib/python1.5/site-packages/", line 942,
in getcompslist self.getheaderlist()

file "/tmp/lib/python1.5/site-packages/, line 930,
in getheaderlist self.method.readheader ()

file "/tmp/lib/python1.5/site-packages/", line 9
in umount return _isys.umount return _isys.umount (what)
system error : (16, device or resource busy)

Note: the graphical installation does not work only text

Please send me an answer if there is error in the
installation files or the installation process.

Waiting for your fedback..


------- Additional Comments From   10/26/99 20:18 -------
I have the same exact bug.  It works perfectly until it says "reading
packages" then boom, Exception Occurs.

Traceback (innermost last)

File "/usr/bin/anaconda.real", line 225, in ?

File "/tmp/lib/python1.5/"

(several more lines like the one above appear)

TypeError: unsubscriptable object

I tried the updated install but still no go.
I am also trying to install from my HD.
And for some reason nomatter what I type at the boot: prompt
it always loads the graphical interface.

Comment 1 Jay Turner 1999-11-30 18:46:59 UTC
There is reason to believe this error is the result of having corrupt or
incomplete RPM files in the source directory.  Please see bug #6438 for details.

*** This bug has been marked as a duplicate of 6438 ***

Note You need to log in before you can comment on or make changes to this bug.