Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594192 - log spam when gethostby*.getanswer gets DNAME
Summary: log spam when gethostby*.getanswer gets DNAME
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc
Version: 4.8
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Andreas Schwab
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks: 660265
TreeView+ depends on / blocked
 
Reported: 2010-05-20 14:41 UTC by Jon Thomas
Modified: 2018-11-14 19:31 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 660265 693611 (view as bug list)
Environment:
Last Closed: 2011-01-26 17:27:59 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jon Thomas 2010-05-20 14:41:18 UTC
The problem is a DNAME is sometimes returned to gethostby*.getanswer. In some cases this leads to a large amount of log messages such as:

 ping: gethostby*.getanswer: asked for "img.muresinfo.ro.nyud.net IN A", got type "DNAME"

The code in question seems to be 

resolv/nss_dns/dns-host.c

if (type != qtype) {
syslog(LOG_NOTICE|LOG_AUTH,
      "gethostby*.getanswer: asked for \"%s %s %s\", got type \"%s\"",
      qname, p_class(C_IN), p_type(qtype),
      p_type(type));
cp += n;
continue; /* XXX - had_error++ ? */
}

Possible ways to eliminate this:
-message should only occur if the answer doesn't also contain a CNAME. If a CNAME is returned, the message is informational and could be considered LOG_INFO. However, I'm not sure that would reduce the amount of output for some users.

-don't produce the message on DNAME

Comment 4 Eric Bachalo 2011-01-26 17:27:59 UTC
This change did not go upstream. I am closing this request for RHEL 4.9.  If/When a change is made in upstream glibc a request to backport to previous RHELs may be requested.


Note You need to log in before you can comment on or make changes to this bug.