Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594070 - RHEL 4 guest fails to get conversion updates via up2date
Summary: RHEL 4 guest fails to get conversion updates via up2date
Keywords:
Status: CLOSED DUPLICATE of bug 594010
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-v2v
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 13:39 UTC by Matthew Booth
Modified: 2010-11-09 13:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 594010
Environment:
Last Closed: 2010-05-25 15:14:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
log during conversion from LIBGUESTFS_TRACE=1 (deleted)
2010-05-21 03:49 UTC, Rita Wu
no flags Details
xenpv-rhel48-rhn log (deleted)
2010-05-21 09:17 UTC, Rita Wu
no flags Details

Description Matthew Booth 2010-05-20 13:39:10 UTC
+++ This bug was initially created as a clone of Bug #594010 +++

Created an attachment (id=415380)
virt-v2v.conf

Description of problem:
The virt-v2v.conf is lower than the guest, so the guest is downgraded to a lower version of kernel.

Version-Release number of selected component (if applicable):
v2v-libvirt-0.8.1-1.el5
virt-v2v-0.6.0-1.el5

How reproducible:
always

Steps to Reproduce:
1. In guest: rhn_register to register rhn
2. convert the guest registered rhn 
 #virt-v2v -f virt-v2v.conf -i libvirtxml -o rhev -osd nfs:/export domain_xml
3. 
  
Actual results:
the guest is still installed the kernel specified in virt-v2v.conf although it is registered rhn.

Expected results:
the guest registered rhn should 

Additional info:
Convert the guest without registering rhn, I'll get the error message:
virt-v2v -f /etc/virt-v2v.conf -i libvirtxml -o rhev -osd nfs:/export /tmp/xen-RHEL-4.8-32-pv.raw.xml
virt-v2v: Failed to install packages using up2date. Error message was: command:  at /usr/lib/perl5/vendor_perl/5.8.8/Sys/VirtV2V/GuestOS/RedHat.pm line 773.

--- Additional comment from rwu@redhat.com on 2010-05-20 06:39:44 EDT ---

Created an attachment (id=415381)
log from LIBGUESTFS_TRACE=1 during conversion

--- Additional comment from rwu@redhat.com on 2010-05-20 06:42:37 EDT ---

Created an attachment (id=415382)
log from virt-inspect before conversion

--- Additional comment from llim@redhat.com on 2010-05-20 08:56:38 EDT ---

Please include the yum.log or up2date log so we can see if the update is successful.

Comment 1 Matthew Booth 2010-05-20 13:40:10 UTC
Could you please include LIBGUESTFS_TRACE=1 output for the RHEL 4 failure?

Comment 2 Rita Wu 2010-05-21 03:49:39 UTC
Created attachment 415564 [details]
log during conversion from LIBGUESTFS_TRACE=1

Comment 3 Rita Wu 2010-05-21 09:17:56 UTC
Created attachment 415620 [details]
xenpv-rhel48-rhn log

Comment 4 Richard W.M. Jones 2010-05-25 15:02:09 UTC
It's unclear to me why this was cloned.  It looks like a straight
dupe of 594010, just that it happens to affect a different guest
type?

Comment 5 Matthew Booth 2010-05-25 15:14:43 UTC
That wasn't clear at the time I cloned it :)

However, it can be closed now.

*** This bug has been marked as a duplicate of bug 594010 ***


Note You need to log in before you can comment on or make changes to this bug.