Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594047 - Subpackage name change causes dependency failures
Summary: Subpackage name change causes dependency failures
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: report
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: beta
: ---
Assignee: Gavin Romig-Koch
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
: 594687 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 12:49 UTC by Jay Turner
Modified: 2015-01-08 00:17 UTC (History)
4 users (show)

Fixed In Version: report-0.15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-24 11:24:39 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jay Turner 2010-05-20 12:49:03 UTC
Description of problem:
With the 0.14-1.el6 version of the package there is a subpackage name change which is causing unresolved dependencies when updating.  This will impact all Beta1 users attempting to update to Beta2.

plugin-RHEL -> plugin-RHEL-bugzilla

Need to add an "Obsoletes: plugin-RHEL" to the new version of the package in order to facilitate the upgrade.

Version-Release number of selected component (if applicable):
0.14-1.el6

How reproducible:
Always

Steps to Reproduce:
1. Attempt to upgrade from older report packages (say from Beta1) to the 0.14-1.el6 version.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jay Turner 2010-05-20 13:37:12 UTC
Actually, I screwed up above.  Here's the specfile diff:

--- report.spec	2010-05-19 17:51:39.000000000 -0400
+++ report.spec.new	2010-05-20 09:34:39.468269717 -0400
@@ -71,6 +71,7 @@
 
 Requires: report = %{version}-%{release}
 Requires: rpm-python
+Obsoletes: report-plugin-RHEL
 
 %description plugin-RHEL-bugzilla
 Plugin template reporter to bugzilla within RHEL
@@ -143,6 +144,7 @@
 Group:          System Environment/Libraries
 Requires: report-plugin-RHEL-bugzilla = %{version}-%{release}
 Provides: report-config-default = %{version}-%{release}
+Obsoletes: report-config-RHEL
 
 %description config-RHEL-bugzilla-redhat-com
 Config for reporter to bugzilla.redhat.com within RHEL

Comment 2 Gavin Romig-Koch 2010-05-20 20:35:52 UTC
fix pushed to fedorahosted src repo.

Comment 3 Gavin Romig-Koch 2010-05-20 20:36:32 UTC
(In reply to comment #1)
> --- report.spec 2010-05-19 17:51:39.000000000 -0400
> +++ report.spec.new 2010-05-20 09:34:39.468269717 -0400

thanks Jay.

                  -gavin...

Comment 5 Gavin Romig-Koch 2010-05-21 14:54:27 UTC
Yes, no problem.

Comment 6 Gavin Romig-Koch 2010-05-21 14:59:40 UTC
*** Bug 594687 has been marked as a duplicate of this bug. ***

Comment 8 Jay Turner 2010-05-24 11:24:25 UTC
Fix confirmed with 0.15-1.el6.  Closing out.


Note You need to log in before you can comment on or make changes to this bug.