Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 594017 - SELinux is preventing /usr/sbin/abrtd "add_name" access on abrt.
Summary: SELinux is preventing /usr/sbin/abrtd "add_name" access on abrt.
Keywords:
Status: CLOSED DUPLICATE of bug 593906
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:b102daed558...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 11:10 UTC by Frank Murphy
Modified: 2010-05-20 13:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-20 13:45:37 UTC


Attachments (Terms of Use)

Description Frank Murphy 2010-05-20 11:10:14 UTC
Summary:

SELinux is preventing /usr/sbin/abrtd "add_name" access on abrt.

Detailed Description:

SELinux denied access requested by abrtd. It is not expected that this access is
required by abrtd and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                system_u:object_r:var_spool_t:s0
Target Objects                abrt [ dir ]
Source                        abrtd
Source Path                   /usr/sbin/abrtd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-1.1.2-1.fc14
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-19.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.34-2.fc14.x86_64
                              #1 SMP Mon May 17 03:51:48 UTC 2010 x86_64 x86_64
Alert Count                   2
First Seen                    Thu 20 May 2010 12:06:23 IST
Last Seen                     Thu 20 May 2010 12:06:23 IST
Local ID                      69ecd55a-ad0f-4856-b3c8-66cd3bf872cf
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1274353583.95:26478): avc:  denied  { add_name } for  pid=2811 comm="abrtd" name="abrt" scontext=unconfined_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_spool_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1274353583.95:26478): arch=c000003e syscall=83 success=no exit=-13 a0=41e791 a1=1ed a2=d a3=0 items=0 ppid=2810 pid=2811 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="abrtd" exe="/usr/sbin/abrtd" subj=unconfined_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,abrtd,abrt_t,var_spool_t,dir,add_name
audit2allow suggests:

#============= abrt_t ==============
allow abrt_t var_spool_t:dir add_name;

Comment 1 Frank Murphy 2010-05-20 11:15:07 UTC
This happened as soon as a reboot after applying local fix for bug:
https://bugzilla.redhat.com/show_bug.cgi?id=593906

This is my local policy for id=593906:
module mypolicy01 1.0;

require {
	type abrt_t;
	type var_spool_t;
	class dir write;
}

#============= abrt_t ==============
#!!!! The source type 'abrt_t' can write to a 'dir' of the following types:
# abrt_var_log_t, rpm_var_run_t, abrt_var_run_t, tmp_t, var_t, sosreport_tmp_t, abrt_tmp_t, var_run_t, rpm_var_cache_t, abrt_var_cache_t, var_log_t, root_t

allow abrt_t var_spool_t:dir write;

Comment 2 Daniel Walsh 2010-05-20 13:45:37 UTC

*** This bug has been marked as a duplicate of bug 593906 ***


Note You need to log in before you can comment on or make changes to this bug.