Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593973 - abrtd start failure after update
Summary: abrtd start failure after update
Keywords:
Status: CLOSED DUPLICATE of bug 593906
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Nikola Pajkovsky
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 08:23 UTC by Jiri Kastner
Modified: 2014-02-02 22:14 UTC (History)
8 users (show)

Fixed In Version: selinux-policy-3.7.19-17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-20 15:28:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jiri Kastner 2010-05-20 08:23:25 UTC
Description of problem:
abrtd not starting after update to version 1.1.2

Version-Release number of selected component (if applicable):
1.1.2

How reproducible:
always

Steps to Reproduce:
1. update abrt to version 1.1.2
2. service abrtd restart
  
Actual results:
#service abrtd restart
Stopping abrt daemon:                                      [FAILED]
Starting abrt daemon: abrtd: Failed to start: timeout waiting for child
                                                           [FAILED]

#grep abrt /var/log/messages
May 20 08:51:05 dhcp-31-29 yum: Updated: abrt-libs-1.1.2-1.el6.x86_64
May 20 08:51:07 dhcp-31-29 yum: Updated: abrt-1.1.2-1.el6.x86_64
May 20 08:51:35 dhcp-31-29 yum: Updated: abrt-plugin-bugzilla-1.1.2-1.el6.x86_64
May 20 08:51:36 dhcp-31-29 yum: Updated: abrt-plugin-ticketuploader-1.1.2-1.el6.x86_64
May 20 08:51:37 dhcp-31-29 yum: Updated: abrt-addon-kerneloops-1.1.2-1.el6.x86_64
May 20 08:51:38 dhcp-31-29 yum: Updated: abrt-plugin-logger-1.1.2-1.el6.x86_64
May 20 08:51:38 dhcp-31-29 yum: Updated: abrt-addon-python-1.1.2-1.el6.x86_64
May 20 08:51:39 dhcp-31-29 yum: Updated: abrt-plugin-sosreport-1.1.2-1.el6.x86_64
May 20 08:51:40 dhcp-31-29 yum: Updated: abrt-addon-ccpp-1.1.2-1.el6.x86_64
May 20 08:52:29 dhcp-31-29 yum: Updated: abrt-gui-1.1.2-1.el6.x86_64
May 20 08:53:43 dhcp-31-29 yum: Updated: abrt-cli-1.1.2-1.el6.x86_64
May 20 09:00:58 dhcp-31-29 yum: Updated: abrt-desktop-1.1.2-1.el6.x86_64
May 20 09:03:08 dhcp-31-29 yum: abrt-desktop: ts_done name in te is libgfortran should be abrt-desktop
May 20 09:03:09 dhcp-31-29 yum: abrt-gui: ts_done name in te is abrt-desktop should be abrt-gui
May 20 09:03:10 dhcp-31-29 yum: firefox: ts_done name in te is abrt-gui should be firefox
May 20 09:03:12 dhcp-31-29 yum: abrt-addon-kerneloops: ts_done name in te is firefox should be abrt-addon-kerneloops
May 20 09:03:12 dhcp-31-29 yum: abrt-addon-ccpp: ts_done name in te is abrt-addon-kerneloops should be abrt-addon-ccpp
May 20 09:03:13 dhcp-31-29 yum: abrt-addon-python: ts_done name in te is abrt-addon-ccpp should be abrt-addon-python
May 20 09:03:14 dhcp-31-29 yum: xulrunner: ts_done name in te is abrt-addon-python should be xulrunner
May 20 09:03:16 dhcp-31-29 yum: abrt-plugin-logger: ts_done name in te is xulrunner should be abrt-plugin-logger
May 20 09:03:16 dhcp-31-29 yum: abrt-plugin-ticketuploader: ts_done name in te is abrt-plugin-logger should be abrt-plugin-ticketuploader
May 20 09:03:17 dhcp-31-29 yum: abrt-plugin-sosreport: ts_done name in te is abrt-plugin-ticketuploader should be abrt-plugin-sosreport
May 20 09:03:18 dhcp-31-29 yum: abrt-plugin-bugzilla: ts_done name in te is abrt-plugin-sosreport should be abrt-plugin-bugzilla
May 20 09:03:19 dhcp-31-29 yum: abrt: ts_done name in te is abrt-plugin-bugzilla should be abrt
May 20 09:03:20 dhcp-31-29 yum: virt-v2v: ts_done name in te is abrt should be virt-v2v
May 20 09:03:23 dhcp-31-29 yum: abrt-libs: ts_done name in te is libguestfs-mount should be abrt-libs
May 20 09:03:24 dhcp-31-29 yum: guestfish: ts_done name in te is abrt-libs should be guestfish
May 20 09:04:38 dhcp-31-29 abrtd: UnRegistered Reporter plugin Bugzilla
May 20 09:04:38 dhcp-31-29 abrtd: UnRegistered Analyzer plugin CCpp
May 20 09:04:38 dhcp-31-29 abrtd: UnRegistered Analyzer plugin Kerneloops
May 20 09:04:38 dhcp-31-29 abrtd: UnRegistered Action plugin KerneloopsScanner
May 20 09:04:38 dhcp-31-29 abrtd: UnRegistered Reporter plugin Logger
May 20 09:04:38 dhcp-31-29 abrtd: UnRegistered Analyzer plugin Python
May 20 09:04:38 dhcp-31-29 abrtd: UnRegistered Action plugin SOSreport
May 20 09:04:38 dhcp-31-29 abrtd: UnRegistered Database plugin SQLite3
May 20 09:04:38 dhcp-31-29 abrtd: UnRegistered Reporter plugin TicketUploader
May 20 09:04:38 dhcp-31-29 abrtd: Got signal 15, exiting
May 20 09:04:38 dhcp-31-29 abrtd: Can't create '/var/spool/abrt': Permission denied
May 20 09:04:38 dhcp-31-29 kernel: type=1400 audit(1274339078.946:32333): avc:  denied  { write } for  pid=20710 comm="abrtd" name="spool" dev=sda3 ino=1966081 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_spool_t:s0 tclass=dir
May 20 09:04:38 dhcp-31-29 kernel: type=1400 audit(1274339078.946:32334): avc:  denied  { write } for  pid=20710 comm="abrtd" name="spool" dev=sda3 ino=1966081 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:var_spool_t:s0 tclass=dir


Expected results:
abrtd will start

Additional info:

Comment 1 Nikola Pajkovsky 2010-05-20 09:46:47 UTC
Update your selinux-policy. Dan wrote policy a few days ago. Should I close it?

Comment 2 Bill Nottingham 2010-05-20 14:36:18 UTC
Please close it as a duplicate of the relevant policy bug.

Comment 3 Denys Vlasenko 2010-05-20 15:28:48 UTC

*** This bug has been marked as a duplicate of bug 593906 ***

Comment 4 Denys Vlasenko 2010-05-20 18:23:35 UTC
Please erase all abrt data (rm -rf /var/*/abrt*; yum erase abrt) (note - this will delete all crashes you currently have) and try this build:

https://brewweb.devel.redhat.com/buildinfo?buildID=132768

It _should_ have it fixed, but confirmation from you will make me feel more sore.

Comment 5 Jiri Kastner 2010-05-21 07:34:43 UTC
confirmed, abrt is starting


Note You need to log in before you can comment on or make changes to this bug.