Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593947 - glibc binutils
Summary: glibc binutils
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: binutils
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Nick Clifton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-20 06:13 UTC by cyrushmh
Modified: 2010-07-13 13:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-13 13:35:31 UTC


Attachments (Terms of Use)

Description cyrushmh 2010-05-20 06:13:37 UTC
[CyrusHMH@localhost mydroid]$ make
============================================
PLATFORM_VERSION_CODENAME=REL
PLATFORM_VERSION=2.1-update1
TARGET_PRODUCT=generic
TARGET_BUILD_VARIANT=eng
TARGET_SIMULATOR=
TARGET_BUILD_TYPE=release
TARGET_ARCH=arm
HOST_ARCH=x86
HOST_OS=linux
HOST_BUILD_TYPE=release
BUILD_ID=ECLAIR
============================================
Install: out/host/linux-x86/framework/apicheck.jar
Install: out/host/linux-x86/framework/clearsilver.jar
Install: out/host/linux-x86/framework/droiddoc.jar
Install: out/host/linux-x86/lib/libneo_util.so
............................................next is usefully:
/usr/bin/ld: out/host/linux-x86/obj/EXECUTABLES/accRuntimeTest_intermediates/runtimeTest.o: undefined reference to symbol 'dlsym@@GLIBC_2.0'
/usr/bin/ld: note: 'dlsym@@GLIBC_2.0' is defined in DSO /lib/libdl.so.2 so try adding it to the linker command line
/lib/libdl.so.2: could not read symbols: Invalid operation
collect2: ld 返回 1
make: *** [out/host/linux-x86/obj/EXECUTABLES/accRuntimeTest_intermediates/accRuntimeTest] 错误 1

2.6.33.4-95.fc13.i686.PAE #1 SMP 
rpm -qf /lib/libdl.so.2
glibc-2.12-1.i686
rpm -qf /usr/bin/ld
binutils-2.20.51.0.2-20.fc13.i686

http://fedoraproject.org/w/index.php?title=UnderstandingDSOLinkChange

Comment 1 cyrushmh 2010-05-21 04:06:03 UTC
I only want to install litter nonfree software....

Comment 2 David Ward 2010-06-03 22:03:44 UTC
Also seeing this bug under Fedora 13 when trying to compile EMANE (http://labs.cengen.com/emane) which uses libACE.

Comment 3 Piscium 2010-06-08 23:05:28 UTC
I have a problem with ld that may or may not be related to this.

Basically I have an embryonic project with a few C and C++ files that compiles, links and runs well in Fedora 12. I upgraded to Fedora 13 and now get link errors. They are pasted below.

----------------------
/usr/bin/ld: myarea.o: undefined reference to symbol 'operator new(unsigned int)@@GLIBCXX_3.4'
/usr/bin/ld: note: 'operator new(unsigned int)@@GLIBCXX_3.4' is defined in DSO /usr/lib/libstdc++.so.6 so try adding it to the linker command line
/usr/lib/libstdc++.so.6: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
----------------------

I found this bug that may or may not be related to this issue:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=41333

And these are the versions of ld:
F12: GNU ld version 2.19.51.0.14-37.fc12 20090722
F13: GNU ld version 2.20.51.0.2-20.fc13 20091009

Comment 4 Piscium 2010-06-09 20:07:24 UTC
I found a solution to my problem with the help of a mailing list I subscribe to. 

Basically it was caused by an issue in my makefile, that was nevertheless working well in Fedora 12, but stopped working for some unknown reason with the Fedora 13 toolchain, probably due to a change in the toolchain.

So my issue is probably unrelated to the original issue in this bug.

Comment 5 Ian Pilcher 2010-07-13 04:57:59 UTC
cyrushmh -

You can work around the link error by applying this patch to
system/core/libacc/tests/Android.mk:

--- Android.mk.orig     2010-07-12 22:28:22.041458153 -0500
+++ Android.mk  2010-07-12 23:39:30.011456227 -0500
@@ -11,6 +11,8 @@
 LOCAL_SHARED_LIBRARIES := \
     libacc
 
+LOCAL_LDLIBS += -ldl
+
 LOCAL_MODULE_TAGS := tests
 
 include $(BUILD_HOST_EXECUTABLE)
@@ -44,6 +46,8 @@
 LOCAL_SHARED_LIBRARIES := \
     libacc
 
+LOCAL_LDLIBS += -ldl
+
 LOCAL_MODULE_TAGS := tests
 
 include $(BUILD_HOST_EXECUTABLE)

Smarter folks that me will have to decide if the change in behavior
(requiring an explicit link to libdl) is a bug or not.

HTH

Comment 6 cyrushmh 2010-07-13 13:35:31 UTC
thanks
I know now


Note You need to log in before you can comment on or make changes to this bug.