Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593702 - [RFE] unrar missing in all RHEL distros up and including RHEL6beta1
Summary: [RFE] unrar missing in all RHEL distros up and including RHEL6beta1
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: distribution
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: RHEL Product and Program Management
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-19 14:28 UTC by Luc de Louw
Modified: 2010-05-19 19:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-19 18:29:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Luc de Louw 2010-05-19 14:28:00 UTC
Description of problem:

Since SAP ships some software components packed with RAR we need to install unrar from third party repositories or from source.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. yum search unrar

  
Actual results:
No Matches found

Expected results:
Matched: unrar

Additional info:

Comment 2 Bill Nottingham 2010-05-19 18:29:43 UTC
To the best of my knowledge, there is no unrar codebase under an acceptable license available.
http://fedoraproject.org/wiki/Licensing/Unrar

Comment 3 Luc de Louw 2010-05-19 18:58:51 UTC
Dear Bill,

This explains why unrar is not in any RH sponsored project (EPEL) 

I had a look to the link you posted. The license is indeed not very comfortable. RH based distros such as RHEL and Fedora are AFAIK the only ditros which are not proving unrar. Even Debian which is know for its quite radical behavior when it comes to licensing questions has unrar available. See http://packages.debian.org/sid/unrar .

OpenSuse as well as SLES11 ships unrar. At the end of the day this means RH is the only Linux vendor that does NOT ship unrar. 

What is so evil with unrar?

The only alternative for us if you intervene @SAP (with is a partner of you) to get rid of this compression alg. 

Sorry, just closing this bug because of such an issue is not acceptable. I thing this needs further discussions.

Thanks,

Luc

Comment 4 Bill Nottingham 2010-05-19 19:30:52 UTC
(In reply to comment #3)
> Sorry, just closing this bug because of such an issue is not acceptable. I
> thing this needs further discussions.

We are not indenting to ship software that has specific use restrictions on the code, for the same reason we don't include software that is 'non-commercial use only', or similar.


Note You need to log in before you can comment on or make changes to this bug.