Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593650 - import wx fails
Summary: import wx fails
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: wxPython
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-19 12:00 UTC by Rakesh Pandit
Modified: 2010-05-27 09:21 UTC (History)
3 users (show)

Fixed In Version: wxPython-2.8.10.1-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-27 09:21:20 UTC


Attachments (Terms of Use)

Description Rakesh Pandit 2010-05-19 12:00:16 UTC
Description of problem:
importing wx fails

>>> import wx
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/__init__.py", line 45, in <module>
    from wx._core import *
  File "/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 14770, in <module>
    from _misc import *
  File "/usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_misc.py", line 4, in <module>
    import _misc_
ImportError: /usr/lib64/python2.6/site-packages/wx-2.8-gtk2-unicode/wx/_misc_.so: symbol _ZN7wxSound6CreateEiPKh, version WXU_2.8 not defined in file libwx_gtk2u_adv-2.8.so.0 with link time reference


Version-Release number of selected component (if applicable):
[rakesh@fedora-rawhide SPECS]$ rpm -qa wxPython
wxPython-2.8.10.1-2.fc14.x86_64
[rakesh@fedora-rawhide SPECS]$ 


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Mads Kiilerich 2010-05-25 22:01:01 UTC
This is a duplicate of bug 587900, but I don't know if the f13 fix has propagated to rawhide yet.

Comment 2 Rakesh Pandit 2010-05-26 03:34:19 UTC
It hasn't been pushed to rawhide that is why I guess is still in rawhide (even though I haven't checked in f13 with update-testing whether new one solves it).


Note You need to log in before you can comment on or make changes to this bug.