Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593591 - Crash when typing some Chinese phrases and move cursor
Summary: Crash when typing some Chinese phrases and move cursor
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ibus-pinyin
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Peng Wu
QA Contact: QE Internationalization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-19 09:13 UTC by Peng Huang
Modified: 2010-10-18 17:02 UTC (History)
7 users (show)

Fixed In Version: ibus-pinyin-1.3.8-1.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-23 06:12:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Peng Huang 2010-05-19 09:13:25 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Enable Pinyin input method
2. Type "pi'ao"
3. Press left arrow to move cursor to the beginning.
4. crash
  
Actual results:
4. crash

Expected results:
does not crash

Additional info:

Comment 1 Peng Huang 2010-05-19 09:14:18 UTC
This bug has been fixed in upstream.

Comment 3 RHEL Product and Program Management 2010-05-19 09:55:06 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Peng Huang 2010-05-31 03:45:20 UTC
Fixed in ibus-pinyin-1.3.8-1.el6.

Comment 9 Kenichi Takemura 2010-07-13 06:55:12 UTC
Hi

I am trying to reproduce this bug to verify
but I cannot reproduce following steps.

Could you give me more detailed steps?

- which application
- you need to hit a space or enter before moving the cursor?

I am testing on 
$ rpm -q ibus-pinyin
ibus-pinyin-1.2.0.20090915-1.fc12.noarch

Comment 10 Kenichi Takemura 2010-07-15 23:55:03 UTC
I could reproduce the bug 

ibus-pinyin-1.3.5-1.el6.x86_64.

Comment 11 Kenichi Takemura 2010-07-15 23:59:11 UTC
Verified.

ibus-pinyin-1.3.8-1.el6.x86_64.

Comment 12 Kenichi Takemura 2010-07-23 06:12:38 UTC
Closing this bug.

Verified on host build from rel-eng/RHEL6.0-20100715.2 tree


Note You need to log in before you can comment on or make changes to this bug.