Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593579 - After upgrade from F11 to F13 some config values not honoured
Summary: After upgrade from F11 to F13 some config values not honoured
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: offlineimap
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Christoph Höger
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-19 08:26 UTC by Amit Shah
Modified: 2010-10-01 05:08 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-01 05:08:42 UTC


Attachments (Terms of Use)

Description Amit Shah 2010-05-19 08:26:36 UTC
Description of problem:

I upgraded my F11 install to F13 by taking a backup of my config files and offlineimap folders and then restoring them in /home.

A few things which worked fine earlier don't work anymore:

- I have the 'socktimeout' value set to 60. After about a min. of inactivity, offlineimap earlier used to exit. It now sits there forever instead of exiting in case of connection loss (n/w cable plugged out, for example).

- I have the autorefresh time set for an account to '5'. Earlier, offlineimap used to wait for 5 mins. Now it just waits for 10s before starting pulling mail again

I diffed my config to the current example config in /usr/share/doc/offlineimap/offlineimap.conf, and there doesn't seem to be much difference in how these values are handled, so I guess it's a regression from F11.

I can provide my config file snippet, but the same config worked on F11 and as I mentioned, the diff to the example one doesn't turn up anything other than my customisations.

Comment 1 Amit Shah 2010-07-02 06:31:49 UTC
Setting autorefresh to 150 now makes offlineimap sleep for 5 mins. The comments still mention that the value is in minutes.

Comment 2 Amit Shah 2010-10-01 05:08:42 UTC
The 6.2.0 update has resolved the autorefresh issue for me -- autorefresh of '5' now makes offlineimap sleep for 5 mins, as documented.

Closing this bug; if the socktimeout value isn't yet honoured, I'll open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.