Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593508 - After changing directory Thunar can't select a file/dir anymore in "detailed list" mode.
Summary: After changing directory Thunar can't select a file/dir anymore in "detailed ...
Keywords:
Status: CLOSED DUPLICATE of bug 579356
Alias: None
Product: Fedora
Classification: Fedora
Component: Thunar
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-19 00:54 UTC by Krzysztof Halasa
Modified: 2010-05-21 00:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-21 00:55:07 UTC


Attachments (Terms of Use)

Description Krzysztof Halasa 2010-05-19 00:54:25 UTC
Description of problem:
After changing directory Thunar can't select a file/dir anymore. This only happens with "view as detailed list" (ctrl-2).

Version-Release number of selected component (if applicable):
Thunar-1.0.1-7.fc13.x86_64 (Fedora 13 prerelease)

How reproducible:
Always

Steps to Reproduce:
1. Start thunar and select "view as detailed list" (ctrl-2).
2. double click on any directory in the right panel to chdir there
3. try to double click on any file or directory to open it or chdir etc.
  
Actual results:
The file/dir in "3" can't be selected and one can't open it, chdir etc.

Expected results:
The file in question should be selected and available for opening etc.

Comment 1 Kevin Fenzi 2010-05-20 02:50:17 UTC
Does the entire Thunar window become unresponsive at that point? 

Or is it still responsive, but you cannot select/open one particular dir?

Comment 2 Krzysztof Halasa 2010-05-20 13:11:38 UTC
Thunar still functions, e.g. I can change dirs using the buttons above the file list or using the left panel, the menu is still functional and I can even right-click on the right panel and the Create Folder/Create Document/etc. pop-up appears. I can't only select individual (any) files/dirs on the right panel, thus I can open them, chdir there and so on. Changing the view to Icons/Compact List fixes the problem temporarily, changing to Detailed List allows for selecting a file/dir once, and it breaks again.
Looks like GTK misuse.

Comment 3 Kevin Fenzi 2010-05-20 15:11:36 UTC
I was wondering if you were seeing another case of bug 579356 here, but it sounds different. 
Just to be sure, can you try updating: 

http://admin.fedoraproject.org/updates/exo-0.3.106-3.fc13

and see if that changes the behavior any?

Comment 4 Christoph Wickert 2010-05-20 15:40:59 UTC
I think both reporters describe the same issue, both are in detailed list view. both have opened a folder with the mouse previously...

I can confirm this behavior when Thunar is set to use double clicks. If single
click is used, everything is fine.

I have updated to exo-0.3.106-3 now and the bug is gone.

Comment 5 Krzysztof Halasa 2010-05-20 23:54:53 UTC
Right, exo-0.3.106-3 fixes this problem for me as well.
Thanks a lot.

Comment 6 Kevin Fenzi 2010-05-21 00:55:07 UTC
Thanks. 

If you could add karma to the above update link that would be great!

*** This bug has been marked as a duplicate of bug 579356 ***


Note You need to log in before you can comment on or make changes to this bug.