Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593442 - clone a disk always says "there are partitions that are not restricted to one device"
Summary: clone a disk always says "there are partitions that are not restricted to one...
Keywords:
Status: CLOSED DUPLICATE of bug 587036
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 19:05 UTC by Hank
Modified: 2010-05-18 19:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 19:11:38 UTC


Attachments (Terms of Use)

Description Hank 2010-05-18 19:05:43 UTC
Description of problem:
During install with multiple drives, if you create a list of partitions and allocate them to one drive (by only checking one box in the disk list) you can never clone that drive because the system always says:
"there are partitions that are not restricted to one device"

using supermicro servers different models past few versions of Fedora Graphical installer

Version-Release number of selected component (if applicable):
12/13beta

How reproducible:
Always http://www.youtube.com/watch?v=IonWCKOzZwk#t=1m30s

Steps to Reproduce:
1. Have 2 or more drives new/blank to use during install
2. Judiciously make 8 or 9 partitions as softRAID and be sure to check the box for only one drive!!
3. Use the clone a drive RAID function
...
This seems to happen with ext3, ext4 and jfs partitions, the system loses track of which drive I have selected whenever I want to clone a drive.
  
Actual results:
"there are partitions that are not restricted to one device"

Expected results:
Wow, you did alot of work allocating all those softRAID partitions and carefully marking them to only use drive a, so I will clone that drive for you to save you further work. Oh, wait, you want to create a spare drive too? OK, I'll clone that one for you, too, really it's no problem, I have the partition listing right here...

Additional info:
been this way for a couple releases, AFAIK

and thank you for your support
http://www.youtube.com/watch?v=w3LkWVqYecE&feature=related#t=27s

Comment 1 Hans de Goede 2010-05-18 19:11:38 UTC
This is "fixed" for F-14, but I'm afraid the fix is not going to make you happy, see the bug this is a duplicate of.

I think the answer for your problems is to use kickstart for advanced setups like these.

*** This bug has been marked as a duplicate of bug 587036 ***

Comment 2 Hank 2010-05-18 19:32:55 UTC
Well, thanks for the instant update - for me, I don't use LVM and on servers I like to keep separate file systems for /usr /var /var/lib/mysql/data /var/lib/mysqllogs /var/lib/mysqldumps, etc.  That way if there is filesystem corruption, it can often be limited to a smaller number of files, etc.
  
So I will just go ahead and create all the partitions manually from now on - or use kickstart.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.