Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593386 - Make check cluster_tests.LongTests.test_failover fails
Summary: Make check cluster_tests.LongTests.test_failover fails
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: beta
Hardware: All
OS: Linux
high
high
Target Milestone: 1.3
: ---
Assignee: Alan Conway
QA Contact: Frantisek Reznicek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 17:31 UTC by Alan Conway
Modified: 2015-11-16 01:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-15 19:24:55 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alan Conway 2010-05-18 17:31:01 UTC
Description of problem:

Make check cluster_tests.LongTests.test_failover fails because of a dropped message. Problem in new API clients qpid_send/qpid_receive (test passed when it was using the old API sender/receiver)

Version-Release number of selected component (if applicable):

svn r945683

How reproducible: easy

Steps to Reproduce:
In a checkout:

cd src/tests; source test_env.sh

while  run_cluster_tests cluster_tests.LongTests.test_failover -DDURATION=2; do true; done

Actual results:

Fails in one or two iterations with:
      assert(m <= self.received) # Check for missing messages

Expected results:

No failures.

Additional info:

Comment 1 Alan Conway 2010-05-18 18:48:45 UTC
Fixed in r945813


Note You need to log in before you can comment on or make changes to this bug.