Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593345 - qemuMonitorJSONHandleIOError:597 : missing reason in disk io error event
Summary: qemuMonitorJSONHandleIOError:597 : missing reason in disk io error event
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Berrange
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 15:06 UTC by Marc Milgram
Modified: 2010-06-22 10:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-22 10:23:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
sos report (deleted)
2010-05-18 15:07 UTC, Marc Milgram
no flags Details

Description Marc Milgram 2010-05-18 15:06:12 UTC
Description of problem:
qemu complains "warning: qemuMonitorJSONHandleIOError:597 : missing reason in disk io error event"

This occurred while installing RHEL6b1 as a guest, and it was accessing the real physical DVD drive.

We believe that there is a problem with the DVD drive, I expect a better error message.

The error message from within the guest indicated reading past end of media - but that is probably wrong too.

Version-Release number of selected component (if applicable):
libvirt-0.8.1-3.el6.x86_64
qemu-img-0.12.1.2-2.53.el6.x86_64
qemu-kvm-0.12.1.2-2.53.el6.x86_64
kernel-2.6.32-25.el6.x86_64

How reproducible:
Unknown

Steps to Reproduce:
1. Install RHEL 6.0 Beta 1 from DVD in a KVM guest

  
Actual results:
Install fails
/var/log/messages shows lots of messages of the form:
May 18 10:56:26 mmilgramd libvirtd: 10:56:26.219: warning : qemuMonitorJSONHandleIOError:597 : missing reason in disk io error event


Expected results:
Install succeeds
No warning messages

Additional info:

Comment 1 Marc Milgram 2010-05-18 15:07:15 UTC
Created attachment 414887 [details]
sos report

Comment 3 RHEL Product and Program Management 2010-05-19 16:35:26 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Daniel Berrange 2010-06-22 10:23:02 UTC

*** This bug has been marked as a duplicate of bug 586353 ***


Note You need to log in before you can comment on or make changes to this bug.