Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5933 - sem_init() function not implemented
Summary: sem_init() function not implemented
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-14 03:00 UTC by mkstreetdog
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 02:33:24 UTC


Attachments (Terms of Use)

Description mkstreetdog 1999-10-14 03:00:36 UTC
The sem_init() function prototype is included in semaphore.h
header file and the libpthread.a library, but when I run a
program using this function an error appears stating that
the function sem_init() is not implemented. Is there another
library I can link into my programs which contains this
function?

Comment 1 mkstreetdog 1999-10-17 06:21:59 UTC
Please disregard this percieved bug, it is not a bug. I didn't read
the man pages (naughty...), process shared semaphores are not
supported in LinuxThreads. Sorry for the wasted space and undue use of
your time. (MK)

Comment 2 Cristian Gafton 2000-02-05 02:33:59 UTC
closed at reporter's request


Note You need to log in before you can comment on or make changes to this bug.