Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593259 - AttributeError: saveFile instance has no attribute 'dialog'
Summary: AttributeError: saveFile instance has no attribute 'dialog'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-kickstart
Version: 6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Chris Lumens
QA Contact: Release Test Team
URL:
Whiteboard: system-config-kickstart_trace_hash:a1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 11:04 UTC by Alexander Todorov
Modified: 2010-11-10 21:42 UTC (History)
0 users

Fixed In Version: system-config-kickstart-2.8.6-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 21:42:36 UTC
Target Upstream Version:


Attachments (Terms of Use)
Attached traceback automatically from system-config-kickstart. (deleted)
2010-05-18 11:04 UTC, Alexander Todorov
no flags Details
a patch (deleted)
2010-05-27 18:36 UTC, Chris Lumens
no flags Details | Diff

Description Alexander Todorov 2010-05-18 11:04:02 UTC
The following was filed automatically by system-config-kickstart:
system-config-kickstart @VERSION@ exception report
Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/savefile.py", line 60, in on_confirm_options_cancel_button
    self.dialog.hide()
AttributeError: saveFile instance has no attribute 'dialog'

Comment 1 Alexander Todorov 2010-05-18 11:04:06 UTC
Created attachment 414806 [details]
Attached traceback automatically from system-config-kickstart.

Comment 3 Alexander Todorov 2010-05-18 11:12:57 UTC
This is with system-config-kickstart-2.8.5-1.el6

In order to test bug #560079 I've installed :
fedora-kickstarts-0.12.0-2.fc12.noarch.rpm
spin-kickstarts-0.12.0-2.fc12.noarch.rpm

To reproduce this do:
1) Start system-config-kickstart (I've started it as root, from command line, inside /usr/share/spin-kickstarts).
2) Open any of the files in this directory. File should load fine.
3) Select File -> Preview (Ctrl+P) then Cancel. Nothing happens.
4) Open another kickstart file from the file menu.
5) Select File -> Preview (Ctrl+P) then Cancel. Traceback happens.

I've tried several different files and it looks like it doesn't matter which files I open. On the second time there's always a crash. 

Perhaps anaconda is not initializing the dialog properly or is destroying it the first time I press Cancel.

Comment 4 Chris Lumens 2010-05-27 17:13:35 UTC
Looks like this only happens if you load a *different* file.  If you reload the same file, no traceback.  Also if you see what's going on when the cancel button is clicked:

(Pdb) dir(self)
['__doc__', '__init__', '__module__', 'buf', 'confirm_buffer', 'confirm_options_cancel_button', 'confirm_options_ok_button', 'destroy', 'dialog', 'on_confirm_options_cancel_button', 'saveFile_cb', 'textview', 'xml']
(Pdb) c

...

> /home/clumens/src/system-config-kickstart/src/savefile.py(62)on_confirm_options_cancel_button()
-> self.dialog.hide()
(Pdb) dir(self)
['__doc__', '__init__', '__module__', 'destroy', 'on_confirm_options_cancel_button', 'saveFile_cb']

So, lots of methods and attributes are getting lost.  Very strange.

Comment 5 Chris Lumens 2010-05-27 18:36:57 UTC
Created attachment 417340 [details]
a patch

Can you apply this patch (patch -p2, I think) to your /usr/share/system-config-kickstart/ contents locally and see if it's working better for you?  I've completely redone the save dialog in the hopes of fixing this problem.  There are some other minor changes, like the icons on the buttons being gone, but I'm not concerned about that.

Comment 7 Alexander Todorov 2010-07-02 10:34:49 UTC
Tested with system-config-kickstart-2.8.6.1-1.el6 in snap #7 and the steps to reproduce in comment #3. I've tried this several times with different ot the same file. There was no traceback. Moving to VERIFIED.

Comment 8 releng-rhel@redhat.com 2010-11-10 21:42:36 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.