Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593251 - Move / delete of files fails if target directory name contains a space
Summary: Move / delete of files fails if target directory name contains a space
Keywords:
Status: CLOSED DUPLICATE of bug 589874
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nautilus
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Tomáš Bžatek
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 10:24 UTC by manuel wolfshant
Modified: 2015-03-03 22:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 11:08:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CentOS 4322 None None None Never

Description manuel wolfshant 2010-05-18 10:24:55 UTC
Description of problem:
delete seems to fail when the folder's name contains spaces

Version-Release number of selected component (if applicable):

nautilus-2.16.2-7.el5

How reproducible:
always

Steps to Reproduce:
A)
1. Create a directory containing a space in the name, e.g. the default "untitled folder".
2. Do a cut operation on a file and try to paste into the folder. You will get an error message "Not on the same filesystem" even though the files are in the same user directory.
3. Edit the directory name to remove the space and the cut and paste operation works. Performing the operation in bash shell using "mv" works correctly with a space in the name, so the problem appears to be in nautilus.
B)
1.create a new directory , leaving the default name
2.paste inside a file
3. try to to delete the file, watch the "Not on the same filesystem" error message
Actual results:
delete fails

Expected results:
the file should be moved in scenario A, respectively deleted in scenario B

Comment 1 Tomáš Bžatek 2010-05-18 11:08:16 UTC
This looks to me like a duplicate of bug 589874. Please test and reopen if it's
still a problem for you.

*** This bug has been marked as a duplicate of bug 589874 ***

Comment 2 manuel wolfshant 2010-05-18 11:42:21 UTC
Is there a way to test without building my own rpm for gnome-vfs2 ?

Comment 3 Tomáš Bžatek 2010-05-18 11:47:00 UTC
The package should appear soon in RHEL 5.5.z channel. Since it contains an updated patch, you need to rebuild the rpm.


Note You need to log in before you can comment on or make changes to this bug.