Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593132 - Not all hugepages are released on database shutdown
Summary: Not all hugepages are released on database shutdown
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Red Hat Kernel Manager
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-17 21:48 UTC by Bill Braswell
Modified: 2018-10-27 15:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-03 16:47:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Bill Braswell 2010-05-17 21:48:11 UTC
Several customers are experiencing a similar problem.  When shutting down a database engine, not all of shared memory is released when hugepages are in use.  This is occurring on systems running Oracle and Sybase as well as on RHEL 5.3 and 5.4.

The amount lost varies from system to system.  But the loss is consistent on each system.  In other words, if the loss is 1 gigabyte, it will always be 1 gigabyte on that system.  Each time the database is started and later stopped, more memory is leaked until there is not enough available to start the database.

The ipcs command shows the shared memory segment as having been released after the database shutdown is complete, but the HugePages_Free field in /proc/meminfo does not show all the memory having been released.

Attempting to manually force the pages to be released by echoing 0 into /proc/sys/vm/nr_hugepages does not seem to have any effect on this issue.

This is the same problem as bz593131 but on 5.4.

Comment 8 Larry Woodman 2010-12-03 16:47:40 UTC

*** This bug has been marked as a duplicate of bug 593131 ***


Note You need to log in before you can comment on or make changes to this bug.