Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5931 - Upgrade hangs if unformatted Linux partition exists
Summary: Upgrade hangs if unformatted Linux partition exists
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-14 02:29 UTC by fred-m
Modified: 2015-01-07 23:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-10-21 18:11:21 UTC


Attachments (Terms of Use)

Description fred-m 1999-10-14 02:29:56 UTC
When I upgraded my RH 6.0 machine with the (awesome)
graphic installer, I had a Linux partition yet unformatted.
When the installer searched for partitions with Red Hat
installed, this partition caused a Python error (visible by
switching the virtual console) and the installer hung.

Formatting that partition with mke2fs solved the problem,
and the upgrade completed smoothly.

Comment 1 Alain RICHARD 1999-10-15 11:11:59 UTC
I have had the same kind of problems with NTFS formated partitions :
mount fails (in my case because there is no NTFS module in the kernel
and in the previouly described case because the ext2 partition is
unformated).

The mount is tried during the initial localisation of a linux root
filesystem.

This bug is 100% reproductible using either graphic or text installer.

A simple fix for me was to change the partition type from 7
(HPFS/NTFS) to 17 (Hidden HPFS/NTFS) using fdisk, running the
installer/upgrader and changing back the partition

Comment 2 Jay Turner 1999-10-21 18:11:59 UTC
*** This bug has been marked as a duplicate of 5618 ***


Note You need to log in before you can comment on or make changes to this bug.