Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593027 - valgrind crashes with segmentation fault on ppc64
Summary: valgrind crashes with segmentation fault on ppc64
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: valgrind
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Jakub Jelinek
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-17 16:16 UTC by Orion Poplawski
Modified: 2011-05-13 12:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-21 08:13:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Orion Poplawski 2010-05-17 16:16:57 UTC
Description of problem:

Trying to build netcdf for EPEL 6 and it fails on pp64.  Task is here:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2192605

First it runs a series of tests, and then it runs them under valgrind.  Tests run fine without valgrind, but segfault under valgrind.  I don't have access to a ppc64 machine at the moment to test with.

Version-Release number of selected component (if applicable):
valgrind-3.5.0-12.el6

Comment 2 Jakub Jelinek 2010-05-18 14:04:32 UTC
Just rerun the failed test under valgrind without -q from the spec file, that will
print out the problem.  An application bug is far more probable than valgrind bug here.  When valgrind segfaults, most of the time it just means the application segfaulted, say accessing a freed block etc.  valgrind message should contain enough info to fix it.

Comment 3 Orion Poplawski 2010-05-19 17:41:24 UTC
I can't reproduce this anymore.


Note You need to log in before you can comment on or make changes to this bug.