Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 593022 - rhel6 Xen guest hangs on boot
Summary: rhel6 Xen guest hangs on boot
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: udev
Version: 6.0
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-17 16:03 UTC by Andrew Jones
Modified: 2011-01-05 10:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 14:48:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Andrew Jones 2010-05-17 16:03:13 UTC
Latest rhel6 compose with the -26 kernel hangs on boot at "Starting plymouth daemon" when booting as a Xen guest.

Guest details: x86_64 PV guest on rhel5.5 host. Host is using LVM for disk image.

Last boot messages:


Write protecting the kernel read-only data: 7196k
dracut: dracut-004-19.el6
dracut: rd_NO_LUKS: removing cryptoluks activation
dracut: rd_NO_LVM: removing LVM activation
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.17.0-ioctl (2010-03-05) initialised: dm-devel@redhat.com
udev: starting version 147
dracut: Starting plymouth daemon

Comment 1 RHEL Product and Program Management 2010-05-17 16:06:01 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Bill Nottingham 2010-05-18 14:05:35 UTC
This is more likely to be a udev-triggered kernel issue. If you try passing 'udevdebug' to the kernel command line, do you get more inforimation?

Comment 3 Andrew Jones 2010-05-18 14:48:10 UTC
Opening grub.conf to add the parameter I saw the problem isn't udev either. The problem is simply that the kernel's rpm script didn't grab the console params from the other kernels (console=tty0 console=hvc0).  So the boot didn't hang, it just stopped outputting. I just 'rpm -e'-ed the kernel and redid the rpm -ivh with the same rpm, and now the console params are there. I don't know what happened, but anyway, long story short, closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.