Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592991 - Anaconda running ssh without root password during install
Summary: Anaconda running ssh without root password during install
Keywords:
Status: CLOSED DUPLICATE of bug 585160
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.1
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-17 14:52 UTC by Mike McGrath
Modified: 2010-05-17 18:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-17 18:38:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mike McGrath 2010-05-17 14:52:12 UTC
Description of problem:
As part of stage 2 it looks like anaconda is running sshd without a root password.

Version-Release number of selected component (if applicable):
RHEL6 beta, x86_64.

How reproducible:
Every time.

Steps to Reproduce:
1.  Try to install RHEL 6.
2.  Once it gets to the partitioning prompt, try to ssh to the host as root.
3.  ssh successful.
  
Actual results:
Full root prompt to a host


Expected results:
Ssh should probably not be running without a special kernel flag like sshenabled=true or something

Additional info:
If you have trouble reproducing let me know, I can send the kickstart file we're using (which currently prompts on new disk partitions.

Comment 2 Vincent Danen 2010-05-17 18:38:22 UTC

*** This bug has been marked as a duplicate of bug 585160 ***


Note You need to log in before you can comment on or make changes to this bug.