Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592966 - System won't hibernate
Summary: System won't hibernate
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: John Feeney
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-17 13:55 UTC by Lubos Kocman
Modified: 2013-01-10 07:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-07 15:43:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lubos Kocman 2010-05-17 13:55:21 UTC
Description of problem:

Thinkpad T400 will not hibernate after pressing Fn+F12. Machine will start hibernation process but it will never finish.

Version-Release number of selected component (if applicable):

Cleanly installed RHEL 6.0 (latest 201005XX from pxe boot).
Installed latest updates for RHEL 6

pm-utils-1.2.5-6.2.el6.x86_64
kernel-2.6.32-25.el6.x86_64



How reproducible:


Steps to Reproduce:
1. press fn+f12 to hibernate suitable RHEL 6.0 system
  
Actual results:

Machine will not finish hibernation process

Expected results:

Machine will hibernate itself.

Additional info:

$ free -m
             total       used       free     shared    buffers     cached
Mem:          3731        977       2754          0        107        436
-/+ buffers/cache:        433       3298
Swap:         4091          0       4091


grub.conf line
title Red Hat Enterprise Linux Workstation (2.6.32-25.el6.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.32-25.el6.x86_64 ro root=/dev/mapper/rootvg-rhel6_root rd_LVM_LV=rootvg/rhel6_root rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet crashkernel=auto
	initrd /initramfs-2.6.32-25.el6.x86_64.img

!!! shouldn't be rd_LVM_LV set to rootvg/lv_swap?

$ grep lv_swap /etc/fstab
/dev/mapper/rootvg-lv_swap swap                    swap    defaults        0 0

Comment 2 Matthew Garrett 2010-06-02 17:46:53 UTC
Can you boot with the no_console_suspend boot argument, switch to a console, log in as root, run pm-hibernate and let me know what the final output is?

Comment 3 RHEL Product and Program Management 2010-06-07 16:03:21 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Lubos Kocman 2010-06-11 08:00:18 UTC
Hello, I booted RHEL with following setup:

title Red Hat Enterprise Linux Workstation (2.6.32-33.el6.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.32-33.el6.x86_64 ro root=/dev/mapper/rootvg-rhel6_root rd_LVM_LV=rootvg/rhel6_root rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet crashkernel=auto no_console_suspend
        initrd /initramfs-2.6.32-33.el6.x86_64.img


I used hibernation via hotkey (fn+F12) and it ended by turning of the laptop. Hibernation diod stopped to blink in the middle of shutdowning process.

(Sorry for delay)

Comment 5 Lubos Kocman 2010-06-11 08:01:12 UTC
Machine is Thinkpad T400 (with latest RHEL6 updates).

Comment 6 Matthew Garrett 2010-06-11 13:24:40 UTC
So it hibernated successfully?

Comment 7 Lubos Kocman 2010-06-23 15:28:12 UTC
Works for me now.

kernel-2.6.32-37.el6.x86_64
pm-utils-1.2.5-7.el6.x86_64

title Red Hat Enterprise Linux Workstation (2.6.32-37.el6.x86_64)
    root (hd0,0)
    kernel /vmlinuz-2.6.32-37.el6.x86_64 ro root=/dev/mapper/rootvg-lv_root rd_LVM_LV=rootvg/lv_root rd_LVM_LV=rootvg/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us crashkernel=auto no_console_suspend


(Works now also without no_console_suspend parameter)


Note You need to log in before you can comment on or make changes to this bug.