Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592916 - IOException: Input/output error during write on /dev/sda
Summary: IOException: Input/output error during write on /dev/sda
Keywords:
Status: CLOSED DUPLICATE of bug 561414
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Kevin Wolf
QA Contact: Virtualization Bugs
URL:
Whiteboard: anaconda_trace_hash:f4dd014daaabf7eeb...
Depends On:
Blocks: 575298
TreeView+ depends on / blocked
 
Reported: 2010-05-17 10:54 UTC by Qian Cai
Modified: 2010-11-11 19:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-20 14:42:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (deleted)
2010-05-17 10:54 UTC, Qian Cai
no flags Details
guest XML (deleted)
2010-05-17 10:59 UTC, Qian Cai
no flags Details

Description Qian Cai 2010-05-17 10:54:23 UTC
The following was filed automatically by anaconda:
anaconda 13.21.39 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/disk.py", line 213, in commit
    return self.__disk.commit()
  File "/usr/lib64/python2.6/site-packages/parted/decorators.py", line 31, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in commit
  File "/usr/lib/anaconda/storage/formats/disklabel.py", line 244, in commit
    self.partedDisk.commit()
  File "/usr/lib/anaconda/storage/devices.py", line 1270, in create
    self.disk.format.commit()
  File "/usr/lib/anaconda/storage/deviceaction.py", line 203, in execute
    self.device.create(intf=intf)
  File "/usr/lib/anaconda/storage/devicetree.py", line 693, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/anaconda/storage/__init__.py", line 292, in doIt
    self.devicetree.processActions()
  File "/usr/lib/anaconda/packages.py", line 109, in turnOnFilesystems
    anaconda.id.storage.doIt()
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1260, in nextClicked
    self.anaconda.dispatch.gotoNext()
IOException: Input/output error during write on /dev/sda

Comment 1 Qian Cai 2010-05-17 10:54:29 UTC
Created attachment 414518 [details]
Attached traceback automatically from anaconda.

Comment 2 Qian Cai 2010-05-17 10:57:27 UTC
Can Reproduce it every time by using the attached guest XML and partitioned rootfs for the USB device.

Comment 3 Qian Cai 2010-05-17 10:59:05 UTC
Created attachment 414519 [details]
guest XML

Comment 4 Hans de Goede 2010-05-17 11:00:47 UTC
From syslog (from the attached logs):

<6>usb 1-1: reset full speed USB device using uhci_hcd and address 2
<6>usb 1-1: reset full speed USB device using uhci_hcd and address 2
<6>usb 1-1: reset full speed USB device using uhci_hcd and address 2
<6>usb 1-1: reset full speed USB device using uhci_hcd and address 2
<6>usb 1-1: reset full speed USB device using uhci_hcd and address 2
<6>usb 1-1: reset full speed USB device using uhci_hcd and address 2
<6>sd 0:0:0:0: [sda] Unhandled error code
<6>sd 0:0:0:0: [sda] Result: hostbyte=DID_ERROR driverbyte=DRIVER_OK
<6>sd 0:0:0:0: [sda] CDB: Write(10): 2a 00 00 00 00 00 00 00 08 00
<3>end_request: I/O error, dev sda, sector 0
<3>Buffer I/O error on device sda, logical block 0
<4>lost page write due to I/O error on sda

So this is a problem with your hardware or the virtual machine, not with anaconda.

Comment 5 Qian Cai 2010-05-17 11:02:46 UTC
All software were from RHEL6.0-20100512.0 tree.

Comment 6 Qian Cai 2010-05-17 11:03:57 UTC
OK, assigned to the virtual component.

Comment 7 RHEL Product and Program Management 2010-05-17 11:04:54 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 8 Kevin Wolf 2010-05-20 14:42:03 UTC

*** This bug has been marked as a duplicate of bug 561414 ***


Note You need to log in before you can comment on or make changes to this bug.