Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592865 - [abrt] crash in xorg-x11-xauth-1:1.0.2-7.fc12: copyAuth: Process /usr/bin/xauth was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in xorg-x11-xauth-1:1.0.2-7.fc12: copyAuth: Process /usr/bin/xau...
Keywords:
Status: CLOSED DUPLICATE of bug 556739
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xauth
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d557e7c3ea8699b673635967cf2...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-17 09:03 UTC by saulo
Modified: 2010-07-06 12:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-06 12:13:48 UTC


Attachments (Terms of Use)

Description saulo 2010-05-17 09:03:29 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/xauth -v -f /home/saulo/.nx/C-SRV-FUNGI-1053-D0DDEC893860C49BEEBCD35EB6A4B64E/authority source /home/saulo/.nx/C-SRV-FUNGI-1053-D0DDEC893860C49BEEBCD35EB6A4B64E/scripts/authority
component: xorg-x11-xauth
crash_function: copyAuth
executable: /usr/bin/xauth
global_uuid: d557e7c3ea8699b673635967cf2a5e90ba86d5b1
kernel: 2.6.32.11-99.fc12.x86_64
package: xorg-x11-xauth-1:1.0.2-7.fc12
rating: 4
reason: Process /usr/bin/xauth was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 Klaus Heinrich Kiwi 2010-07-06 12:06:00 UTC
Package: xorg-x11-xauth-1:1.0.2-7.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Install nomachine nxserver
2. Log in once. Log-off
3. Try logging back in, which fails with the above sigsegv. Remove ~/.Xauthority* and ~/.nx to get it to work again

Comment
-----
This bug report used the nxserver downloaded from www.nomachine.com, but I was able to reproduce the issue with freenx-server from fedora.

freenx-server in general is very poorly documented, and wont 'just work' unfortunately.

Comment 2 Klaus Heinrich Kiwi 2010-07-06 12:09:56 UTC
FYI, I have SELinux disabled in my system.

Comment 3 Klaus Heinrich Kiwi 2010-07-06 12:13:48 UTC
Hm, I belive this is a duplicate of #556739, but feel free to revert otherwise.

*** This bug has been marked as a duplicate of bug 556739 ***


Note You need to log in before you can comment on or make changes to this bug.