Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592795 - [Beaker] bkr list-labcontrollers fails with Traceback
Summary: [Beaker] bkr list-labcontrollers fails with Traceback
Keywords:
Status: CLOSED DUPLICATE of bug 590528
Alias: None
Product: Beaker
Classification: Community
Component: command line
Version: 0.5
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: ---
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-16 23:36 UTC by Jiri Hladky
Modified: 2014-08-12 04:32 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 541287
Environment:
Last Closed: 2010-05-17 07:10:32 UTC


Attachments (Terms of Use)

Description Jiri Hladky 2010-05-16 23:36:50 UTC
Hello,

I have tried to install beaker client on Fedora 12, x86_64 following user guide at
https://engineering.redhat.com/trac/rhat/wiki/BeakerUserGuide

brk is not working at all

Traceback:
=====================================================================
python -m pdb /usr/bin/bkr list-labcontrollers
> /usr/bin/bkr(3)<module>()
-> __requires__ = 'bkr.client==0.5.35'
(Pdb) c
Traceback (most recent call last):
  File "/usr/lib64/python2.6/pdb.py", line 1283, in main
    pdb._runscript(mainpyfile)
  File "/usr/lib64/python2.6/pdb.py", line 1202, in _runscript
    self.run(statement)
  File "/usr/lib64/python2.6/bdb.py", line 368, in run
    exec cmd in globals, locals
  File "<string>", line 1, in <module>
  File "/usr/bin/bkr", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2562, in <module>
    working_set.require(__requires__)
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 626, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 524, in resolve
    raise DistributionNotFound(req)  # XXX put more info here
DistributionNotFound: bkr.client==0.5.35
Uncaught exception. Entering post mortem debugging
Running 'cont' or 'step' will restart the program
> /usr/lib/python2.6/site-packages/pkg_resources.py(524)resolve()
-> raise DistributionNotFound(req)  # XXX put more info here
===================================================================


Installed packages:

Name        : beaker-client
Version     : 0.5.35       
Release     : 2.el5        

Name        : beaker
Version     : 0.5.35
Release     : 2.el5 

Name        : python 
Version     : 2.6.2  
Release     : 4.fc12 


I'm not sure if it's related to this problem, but I have noticed that I have python2.6 installed and beaker client has been installed into
 /usr/lib/python2.4/site-packages/
directory.

Thanks
Jirka

Comment 1 Raymond Mancy 2010-05-17 04:48:21 UTC
beaker-client will work fine on RHEL, but not Fedora. I was able though to make a beaker-client RPM (that worked) in F11 from source without any trouble. So I don't imagine it would be too hard to make an F12 beaker-client rpm available at some point.

Comment 2 Marian Csontos 2010-05-17 07:10:32 UTC

*** This bug has been marked as a duplicate of bug 590528 ***


Note You need to log in before you can comment on or make changes to this bug.