Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592757 - [abrt] crash in gource-0.24-3.fc13: raise: Process /usr/bin/gource was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in gource-0.24-3.fc13: raise: Process /usr/bin/gource was killed...
Keywords:
Status: CLOSED DUPLICATE of bug 589348
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1d4f7460f0dcaac1f52191a4945...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-16 17:42 UTC by Paul W. Frields
Modified: 2010-11-02 03:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-02 03:46:31 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-16 17:42 UTC, Paul W. Frields
no flags Details

Description Paul W. Frields 2010-05-16 17:42:49 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: gource -s 0.1
comment: Gource crashes on git repositories
component: gource
crash_function: raise
executable: /usr/bin/gource
global_uuid: 1d4f7460f0dcaac1f52191a4945fd3295d2a86f5
kernel: 2.6.33.3-85.fc13.x86_64
package: gource-0.24-3.fc13
rating: 4
reason: Process /usr/bin/gource was killed by signal 6 (SIGABRT)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. git clone git://git.fedorahosted.org/git/pulsecaster.git
2. cd pulsecaster
3. gource

Comment 1 Paul W. Frields 2010-05-16 17:42:51 UTC
Created attachment 414389 [details]
File: backtrace

Comment 2 Paul W. Frields 2010-05-16 17:45:55 UTC
http://code.google.com/p/gource/issues/detail?id=72

Upstream issue filed as well.

Comment 3 Paul W. Frields 2010-05-16 17:47:12 UTC
Note upstream issue was filed against 0.26b, which I built for F-13 including the necessary patch for libGL.  However, the problem occurs in the 0.24 version that's currently in the F-13 repo as well.

Comment 4 Paul W. Frields 2010-05-16 17:54:42 UTC
Looks like this is a problem with nouveau_dri.so which is part of mesa-dri-drivers-experimental.  When I remove mesa-dri-drivers-experimental, gource works fine and does not crash as above.

Comment 5 Ben Skeggs 2010-11-02 03:46:31 UTC

*** This bug has been marked as a duplicate of bug 589348 ***


Note You need to log in before you can comment on or make changes to this bug.