Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592735 - Poor performances of the ath9k driver with Atheros AR9285 wireless
Summary: Poor performances of the ath9k driver with Atheros AR9285 wireless
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-16 15:31 UTC by Sébastien Wilmet
Modified: 2012-02-05 15:53 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-12 19:23:51 UTC


Attachments (Terms of Use)

Description Sébastien Wilmet 2010-05-16 15:31:27 UTC
Description of problem:
I have a Sony Vaio VPC-EB1S1E with an Atheros AR9285 card, and the wireless has very poor performances. I've installed compat-wireless, but the problem is still there.

Version-Release number of selected component (if applicable):
kernel-2.6.33.3-85.fc13
compat-wireless-2.6.33.2

How reproducible:
Every time
  
Actual results:
Poor performances

Expected results:
Good performances (as good as with Windows)

Additional info:
$ lspci -v
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
	Subsystem: Foxconn International, Inc. Device e017
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at f4a00000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [60] Express Legacy Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 00-15-17-ff-ff-24-14-12
	Capabilities: [170] Power Budgeting <?>
	Kernel driver in use: ath9k
	Kernel modules: ath9k

Comment 1 Naresh 2010-05-17 11:24:30 UTC
same for me too, wifi is really slow in Fedora-13

02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
        Subsystem: Foxconn International, Inc. Device e017
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at e7a00000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: ath9k
        Kernel modules: ath9k

Comment 2 Naresh 2010-05-20 03:04:05 UTC
updated to 2.6.33.4-96.fc13.x86_64 from koji, now its looking better.

Comment 3 Sébastien Wilmet 2010-05-21 19:19:26 UTC
Yes, the bandwidth is now normal with the 2.6.33.4 version.
But before closing the bug I prefer to be sure that everything is OK.

Comment 4 Sébastien Wilmet 2010-05-22 12:33:09 UTC
With kernel-2.6.33.4-95.fc13 I think I have the same problem as described in this bug report :

https://bugzilla.kernel.org/show_bug.cgi?id=15313

Here is the result of a ping command with kernel 2.6.33.4 :
--- google.com ping statistics ---
36 packets transmitted, 34 received, 5% packet loss, time 35709ms
rtt min/avg/max/mdev = 41.452/98.474/498.712/115.654 ms

With kernel-2.6.34-2.fc14 from rawhide, less packets are lost and it's much faster :
--- google.com ping statistics ---
61 packets transmitted, 60 received, 1% packet loss, time 60185ms
rtt min/avg/max/mdev = 43.215/45.926/104.230/8.115 ms

Comment 5 Sébastien Wilmet 2010-05-25 21:32:21 UTC
There are sometimes problems. But it's difficult to diagnose.

I was downloading a file via bittorrent, the speed was very good. But when a clicked on a link to open a new web page, the ping reported a lot of packet loss and the bit-rate of the file on bittorrent became suddenly very low. The web page (on wikipedia) have taken a lot of time to be completely charged.
Just after that the page was completely charged, the connection was back to a normal state. I tried to charge a new page, and the same problem occurred.

A bit later I tried again and the problem had disappeared...

Here is a ping result when the page was charging (before and after, the connection was normal: no packet loss and a much faster speed):

$ ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=9874 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=11697 ms
64 bytes from 192.168.1.1: icmp_seq=14 ttl=64 time=1.82 ms
64 bytes from 192.168.1.1: icmp_seq=15 ttl=64 time=383 ms
64 bytes from 192.168.1.1: icmp_seq=16 ttl=64 time=2887 ms
64 bytes from 192.168.1.1: icmp_seq=17 ttl=64 time=2824 ms
64 bytes from 192.168.1.1: icmp_seq=18 ttl=64 time=3963 ms
64 bytes from 192.168.1.1: icmp_seq=25 ttl=64 time=2.04 ms
64 bytes from 192.168.1.1: icmp_seq=26 ttl=64 time=1809 ms
64 bytes from 192.168.1.1: icmp_seq=27 ttl=64 time=3171 ms
64 bytes from 192.168.1.1: icmp_seq=28 ttl=64 time=2485 ms
64 bytes from 192.168.1.1: icmp_seq=29 ttl=64 time=6418 ms
64 bytes from 192.168.1.1: icmp_seq=30 ttl=64 time=10086 ms
64 bytes from 192.168.1.1: icmp_seq=31 ttl=64 time=11649 ms
64 bytes from 192.168.1.1: icmp_seq=42 ttl=64 time=1.83 ms
64 bytes from 192.168.1.1: icmp_seq=46 ttl=64 time=14.1 ms
64 bytes from 192.168.1.1: icmp_seq=47 ttl=64 time=87.1 ms
64 bytes from 192.168.1.1: icmp_seq=55 ttl=64 time=1.83 ms
64 bytes from 192.168.1.1: icmp_seq=57 ttl=64 time=1.88 ms
64 bytes from 192.168.1.1: icmp_seq=58 ttl=64 time=2300 ms
64 bytes from 192.168.1.1: icmp_seq=59 ttl=64 time=3040 ms
64 bytes from 192.168.1.1: icmp_seq=60 ttl=64 time=3576 ms
64 bytes from 192.168.1.1: icmp_seq=61 ttl=64 time=3497 ms
^C
--- 192.168.1.1 ping statistics ---
65 packets transmitted, 23 received, 64% packet loss, time 69700ms
rtt min/avg/max/mdev = 1.824/3468.620/11697.203/3773.508 ms, pipe 11

Comment 6 Giovanni Leggio 2010-07-05 06:48:31 UTC
Same problem here with kernel 2.6.33.5-124.fc13.i686.PAE on Fedora 13

wlan0     IEEE 802.11bgn  ESSID:"FASTWEB-1-001CA2C0A958"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 00:1C:A2:C0:A9:58   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=66/70  Signal level=-44 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

04:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
        Subsystem: Device 1a3b:1089
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 18
        Region 0: Memory at febf0000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: <access denied>
        Kernel driver in use: ath9k
        Kernel modules: ath9k

Poor performance (problems with ssh and ftp) with the ethernet everything work fine.

Comment 7 ronw 2010-07-06 17:56:59 UTC
Hi. I had the same problem with 2.6.33 kernel in Arch Linux. I used ndiswrapper to work around it. But since I upgraded to 2.6.34 kernel, the problem disappeared. I have switched back to using ath9k, and there is no packet loss anymore.

Comment 8 ronw 2010-07-06 18:00:30 UTC
Sorry, forgot to mention: I have a HP Compaq Mini 311C netbook with AR9285 wifi card.

Comment 9 Giovanni Leggio 2010-07-06 18:05:17 UTC
Solved with these drivers: http://linuxwireless.org/
now the ping times are fine

Comment 10 ronw 2010-07-06 18:12:12 UTC
Ah, what a fail, I accidentally commented into the redhat.com bugzilla, instead of the kernel.org one (which has the same bug). Sorry :).

Comment 11 martin 2010-09-02 19:59:50 UTC
Instead of opening a separate bug I'll just reuse this one. ;)

I have a Sony Vaio W21Z with a Atheros AR9285 WiFi PCI-Express card (168c:002b (rev 01)) and I get packet loss like in comment #5. I've tried the following kernels:

2.6.35.4-12.fc14.i686
2.6.34.6-47.fc13.i686
2.6.33.8-149.fc13.i686
2.6.33.3-85.fc13.i686

It behaves exactly the same in all versions; massive packet loss (50% or more) and occasional link drops. I always have packet loss (even though it varies) despite having good reception.

Comment 12 Sébastien Wilmet 2010-09-06 10:43:50 UTC
I still have the problem with 2.6.36-rc3.
I tried ndiswrapper but it's worse.

Comment 13 martin 2010-09-06 11:02:36 UTC
@ Sébastien Wilmet:

I just got it to work (half an hour ago) on my Fedora 13. Go to http://linuxwireless.org/en/users/Drivers/ath9k and follow the instructions. Seems to work like a charm, even though I haven't had time to do stress tests yet. At least my ~70% packet loss are gone now! Big improvment. :)

As far as I can tell there's no way you can get neither the rpm-packaged kernels nor the packages from kernel.org to handle the wlan correctly since only part of the patches from linuxwireless has been accepted in the kernel.

Comment 14 Stanislaw Gruszka 2010-09-06 12:16:30 UTC
Hi Martin. Just for sure, you are talking about drivers from compat-wireless http://linuxwireless.org/en/users/Download/stable/ , right?

Comment 15 martin 2010-09-06 12:24:24 UTC
Yep. The file I downloaded is called compat-wireless-2.6.tar.bz2 and contained a directory named compat-wireless-2010-09-05 so it seems to be latest and greatest. One patch didn't apply correctly when it built the drivers but it seems to work anyway. What could POSSIBLY go wrong...!?

Now I only have to get my damn Qualcomm Gobi 2000 to work too, but so far I haven't had much success. However, that's a bit off topic on this bug but anyone having ideas and suggestions are more than welcome to send me a mail... ;)

Comment 16 Sébastien Wilmet 2010-09-06 13:31:27 UTC
With the latest compat-wireless everything is working fine.
Thanks Martin.

Comment 17 Naresh 2010-09-10 17:00:25 UTC
when i last checked, these are the combinations that are working for me (after trying out many kernel versions. After that i have stopped upgrading kernel)

[root@localhost ~]# uname -r
2.6.34.2-33.fc13.x86_64

/home/compat-wireless-2010-08-04/drivers/net/wireless/ath/ath9k/ath9k_hw.ko

Comment 18 Baleta 2010-11-21 02:45:24 UTC
Description of problem:
I have a Sony Vaio VPCCW27FX with an Atheros AR9285 card, and the wireless has
very poor performances. Can you help me ?

Version-Release number of selected component (if applicable):
kernel-2.6.35.6-48.fc14.x86_64

How reproducible:
Every time

Actual results:
Poor performances

Expected results:
Good performances (as good as with Windows)

Additional info:
$ lspci -v
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
	Subsystem: Foxconn International, Inc. Device e017
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at e7a00000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [60] Express Legacy Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 00-15-17-ff-ff-24-14-12
	Capabilities: [170] Power Budgeting <?>
	Kernel driver in use: ath9k
	Kernel modules: ath9k

Comment 19 Baleta 2010-11-21 02:48:05 UTC
Description of problem:
I have a Sony Vaio VPCCW27FX with an Atheros AR9285 card, and the wireless has
very poor performances. Can you help me ?

Version-Release number of selected component (if applicable):
kernel-2.6.35.6-48.fc14.x86_64

How reproducible:
Every time

Actual results:
Poor performances

Expected results:
Good performances (as good as with Windows)

Additional info:
$ lspci -v
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
	Subsystem: Foxconn International, Inc. Device e017
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at e7a00000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [60] Express Legacy Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 00-15-17-ff-ff-24-14-12
	Capabilities: [170] Power Budgeting <?>
	Kernel driver in use: ath9k
	Kernel modules: ath9k

Comment 20 Rudd-O DragonFear 2012-02-05 15:42:43 UTC
I have the same problem.  65 to 500 ms latency in ping times directly to the router.  It's crazy.  Both kernel 3.3rc2 and the latest updated fedora 16 kernel have this problem.

Comment 21 Rudd-O DragonFear 2012-02-05 15:53:12 UTC
Downgrading to wireless B on the wireless router solves it for the most part.  Turning off power management in the card essentially solves the rest of the network jitter.

This network card is a POS.

By the way, the router is not a problem.  Tested with multiple computers, all of them work fine against the router.


Note You need to log in before you can comment on or make changes to this bug.