Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592723 - No more wireless led trigger in Fedora 13?
Summary: No more wireless led trigger in Fedora 13?
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: wireless-tools
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-16 14:44 UTC by Adrian Dinita
Modified: 2010-05-17 17:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-17 17:02:38 UTC


Attachments (Terms of Use)

Description Adrian Dinita 2010-05-16 14:44:26 UTC
Description of problem:

I have an HP Compaq 8510w laptop that shows the wireless led in the section over the keyboard. By default, this led would blink every time traffic goes through the wireless interface. This "default" behaviour is very annoying/distracting. In F12 I managed to keep the led always ON by issuing the following command:
echo none >  /sys/class/leds/iwl-phy0\:\:assoc/trigger  

It seems that in F13 I can no longer do that because I can't find the iwl-phy0 attributes.

Version-Release number of selected component (if applicable):

kernel-2.6.33.3-85.fc13.i686.PAE


How reproducible:
10/10

Steps to Reproduce:

ls /sys/class/leds/
hp::hddprotect  mmc0::


ls /sys/class/net/wlan0/
address   broadcast  device  dormant  features  ifalias  iflink     mtu        phy80211  speed       subsystem     type    wireless
addr_len  carrier    dev_id  duplex   flags     ifindex  link_mode  operstate  power     statistics  tx_queue_len  uevent  

Expected results:

Change the default behaviour to blink only when searching/connecting to the wireless network. 
Or provide the means to disable led blinking.

Comment 1 John W. Linville 2010-05-17 17:02:38 UTC
The change is intentional.  I'm sorry it disables your workaround, but I don't predict it to change back to the other way.

commit e932a609e9759cc75db0c234f465a5fd6e20d362
Author: Johannes Berg <johannes@sipsolutions.net>
Date:   Fri Oct 2 13:44:03 2009 -0700

    iwlwifi: LED cleanup
    
    The iwlwifi drivers have LED blinking requirements that
    mac80211 cannot fulfill due to the use of just a single
    LED instead of different ones for TX, RX, radio etc.
    Instead, the single LED blinks according to transfers
    and is solid on the rest of the time. As such, having
    LED class devices registered that mac80211 triggers are
    connected to is pointless as we don't use the triggers
    anyway.
    
    Remove all the useless code and add hooks into the
    driver itself. At the same time, make the LED code
    abstracted so the core code that determines blink rate
    etc. can be shared between 3945 and agn in iwlcore.
    
    At the same time, the fact that we removed the use of
    the mac80211 LED triggers means we can also remove the
    IWLWIFI_LEDS Kconfig symbol since the LED support is
    now self-contained.
    
    Signed-off-by: Johannes Berg <johannes@sipsolutions.net>
    Signed-off-by: Reinette Chatre <reinette.chatre@intel.com>
    Signed-off-by: John W. Linville <linville@tuxdriver.com>


Note You need to log in before you can comment on or make changes to this bug.