Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592709 - [abrt] crash in telepathy-butterfly-0.5.9-1.fc12: switchboard.py:178:leave:AssertionError
Summary: [abrt] crash in telepathy-butterfly-0.5.9-1.fc12: switchboard.py:178:leave:As...
Keywords:
Status: CLOSED DUPLICATE of bug 577739
Alias: None
Product: Fedora
Classification: Fedora
Component: telepathy-butterfly
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cbd01076
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-16 12:28 UTC by Tamer
Modified: 2010-05-20 22:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-20 22:37:48 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-16 12:28 UTC, Tamer
no flags Details

Description Tamer 2010-05-16 12:28:17 UTC
abrt 1.0.9 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/libexec/telepathy-butterfly
component: telepathy-butterfly
executable: /usr/libexec/telepathy-butterfly
kernel: 2.6.32.11-99.fc12.i686.PAE
package: telepathy-butterfly-0.5.9-1.fc12
reason: switchboard.py:178:leave:AssertionError
release: Fedora release 12 (Constantine)

backtrace
-----
switchboard.py:178:leave:AssertionError

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/papyon/client.py", line 364, in disconnected
    self._dispatch("on_client_error", ClientErrorType.NETWORK, reason)
  File "/usr/lib/python2.6/site-packages/papyon/event/__init__.py", line 44, in _dispatch
    if event_handler._dispatch_event(name, *args):
  File "/usr/lib/python2.6/site-packages/papyon/event/__init__.py", line 65, in _dispatch_event
    handler(*params)
  File "/usr/lib/python2.6/site-packages/butterfly/connection.py", line 382, in on_client_error
    self._new_client(use_http=True)
  File "/usr/lib/python2.6/site-packages/butterfly/connection.py", line 136, in _new_client
    self._msn_client.logout()
  File "/usr/lib/python2.6/site-packages/papyon/client.py", line 264, in logout
    self._switchboard_manager.close()
  File "/usr/lib/python2.6/site-packages/papyon/switchboard_manager.py", line 220, in close
    switchboard.leave()
  File "/usr/lib/python2.6/site-packages/papyon/msnp/switchboard.py", line 178, in leave
    assert(self.state == ProtocolState.OPEN)
AssertionError

Local variables in innermost frame:
self: <SwitchboardProtocol object at 0xa40902c (papyon+msnp+switchboard+SwitchboardProtocol at 0xa4a7f80)>

Comment 1 Tamer 2010-05-16 12:28:30 UTC
Created attachment 414346 [details]
File: backtrace

Comment 2 Brian Pepple 2010-05-20 22:37:48 UTC

*** This bug has been marked as a duplicate of bug 577739 ***


Note You need to log in before you can comment on or make changes to this bug.